【PAT】【Advanced Level】1057. Stack (30)

15 篇文章 0 订阅
10 篇文章 0 订阅

1057. Stack (30)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<= 105). Then N lines follow, each contains a command in one of the following 3 formats:

Push  key
Pop
PeekMedian

where key is a positive integer no more than 105.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print "Invalid" instead.

Sample Input:
17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop
Sample Output:
Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid
原题链接:

https://www.patest.cn/contests/pat-a-practise/1057

思路:

两个set,分别存放上下一半

开数组记录重复的元素(也可以用multiset)

插入时,先插入元素较少的set,然后调整,使得第一个的最大值不大于第二个的最小值。

删除时,先找,再删,然后调整两个set的大小为一样或者差一个。

查询时,若为奇数个,取大的begin()

否则取小的end()

坑:

用scanf、printf读写,否则超时

CODE:

#include<iostream>
#include<cstring>
#include<string>
#include<set>
#include<cstdio>
#include<stack>
#define N 100100
using namespace std;
stack<int> st;
set<int> s1;
int n1[N];
int size1;
set<int> s2;
int n2[N];
int size2;
int main()
{
	memset(n1,0,sizeof(n1));
	memset(n2,0,sizeof(n2));
	int n;
	cin>>n;
	int to=-1;
	size1=0;
	size2=0;
	for (int i=0;i<n;i++)
	{
		char t[10];
		scanf("%s",t);
		if (t[1]=='o')
		{
			if (st.empty())
			{
				printf("Invalid\n");
			}
			else
			{
				int _top=st.top();
				st.pop();
				printf("%d\n",_top);
				if (n1[_top]!=0)
				{
					n1[_top]--;
					size1--;
					if (n1[_top]==0)	s1.erase(s1.find(_top));
					while (size1<size2-1)
					{
						int b=*s2.begin();
						if (n2[b]==1) s2.erase(s2.find(b));
						n2[b]--;
						size2--;
						if (n1[b]==0) s1.insert(b);
						n1[b]++;
						size1++;
					}
				}
				else
				{
					n2[_top]--;
					size2--;
					if (n2[_top]==0)	s2.erase(s2.find(_top));
					while (size2<size1)
					{
						int a=*s1.rbegin();
						if (n1[a]==1) s1.erase(s1.find(a));
						n1[a]--;
						size1--;
						if (n2[a]==0) s2.insert(a);
						n2[a]++;
						size2++;
					}
				}
			}
		}
		else if (t[1]=='u')
		{
			scanf("%d",&to);
			st.push(to);
			if (size1 < size2)
			{
				size1++;
				if (n1[to]==0)	s1.insert(to);
				n1[to]++;			
			}
			else
			{
				size2++;
				if (n2[to]==0)	s2.insert(to);
				n2[to]++;
			}
			if (s1.empty()) continue;
			while (*s1.rbegin()>*s2.begin())
			{
				int a=*s1.rbegin();
				int b=*s2.begin();
				
				if (n1[a]==1)	s1.erase(s1.find(a));
				n1[a]--;

				if (n2[b]==1)	s2.erase(s2.find(b));
				n2[b]--;

				if (n1[b]==0)	s1.insert(b);
				n1[b]++;
					
				if (n2[a]==0)	s2.insert(a);
				n2[a]++;
			}	
		}
		else 
		{
			if (st.empty())
			{
				printf("Invalid\n");
			}
			else
			{
				if (size1<size2)
				{
					int a=*s2.begin();
					printf("%d\n",a);
				}
				else
				{
					int a=*s1.rbegin();
					printf("%d\n",a);
				}
			}
		}
	}	
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值