Target runtime Apache Tomcat v8.0 is not defined.错误解决方法

新导入的一个web工程,在problems中显示错误是:Target runtime Apache Tomcatv8.0 is not defined. 终于找到解决方法。方法是:在工程目录下的.settings文件夹里,打开org.eclipse.wst.common.project.facet.core.xml文件,其内容是:

<?xmlversion="1.0"encoding="UTF-8"?>
<
faceted-project>
<
runtimename="Apache Tomcat v8.0"/>
<
fixedfacet="jst.web"/>
<
fixedfacet="jst.java"/>
<
installedfacet="jst.java"version="6.0"/>
<
installedfacet="jst.web"version="2.5"/>
<
installedfacet="wst.jsdt.web"version="1.0"/>
</
faceted-project>


修改方法是:新建一个web工程,找到工程目录下的.settings文件夹里,打开org.eclipse.wst.common.project.facet.core.xml文件,将其复制替换导入的工程下的org.eclipse.wst.common.project.facet.core.xml内容即可。


本人使用的MyEclipse版本是MyEclipse10

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页