uva 10285 Longest Run on a Snowboard (DP)

Longest Run on a Snowboard

Input: standard input

Output: standard output

Time Limit: 5 seconds

Memory Limit: 32 MB

Michael likes snowboarding. That's not very surprising, since snowboarding is really great. The bad thing is that in order to gain speed, the area must slide downwards. Another disadvantage is that when you've reached the bottom of the hill you have to walk up again or wait for the ski-lift.

Michael would like to know how long the longest run in an area is. That area is given by a grid of numbers, defining the heights at those points. Look at this example:

1� 2� 3� 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

One can slide down from one point to a connected other one if and only if the height decreases. One point is connected to another if it's at left, at right, above or below it. In the sample map, a possible slide would be 24-17-16-1 (start at 24, end at 1). Of course if you would go 25-24-23-...-3-2-1, it would be a much longer run. In fact, it's the longest possible.

Input

The first line contains the number of test cases N. Each test case starts with a line containing the name (it's a single string), the number of rows R and the number of columns C. After that follow R lines with C numbers each, defining the heights. R and C won't be bigger than 100, N not bigger than 15 and the heights are always in the range from 0 to 100.

For each test case, print a line containing the name of the area, a colon, a space and the length of the longest run one can slide down in that area.

Sample Input
2
Feldberg 10 5
56 14 51 58 88
26 94 24 39 41
24 16 8 51 51
76 72 77 43 10
38 50 59 84 81
5 23 37 71 77
96 10 93 53 82
94 15 96 69 9
74 0 62 38 96
37 54 55 82 38
Spiral 5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

Feldberg: 7
Spiral: 25
 
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;

const int maxn = 110;
const int dr[4] = {0 , 0 , -1 , 1};
const int dl[4] = {1 , -1 , 0 , 0};
int N , n , m;
int h[maxn][maxn] , dp[maxn][maxn];
struct Moutain{
	int x , y , h;
	Moutain(int a = 0 , int b = 0 , int c = 0){
		x = a, y = b , h = c;
	}
};
vector<Moutain> M;
int ans;
string Name;

bool cmp(Moutain m1 , Moutain m2){
	return m1.h>m2.h;
}

void initial(){
	for(int i = 0;i < maxn;i++){
		for(int j = 0;j < maxn;j++){
			h[i][j] = maxn;
			dp[i][j] = 0;
		}
	}
	ans = 0;
	M.clear();
}

void readcase(){
	cin >> Name >> n >> m;
	for(int i = 1;i <= n;i++){
		for(int j =1;j <= m;j++){
			cin >> h[i][j];
			M.push_back(Moutain(i , j , h[i][j]));
		}
	}
}

void computing(){
	sort(M.begin() , M.end() , cmp);
	for(int i = 0;i < M.size();i++){
		for(int k = 0;k < 4;k++){
			if(h[M[i].x+dr[k]][M[i].y+dl[k]] < h[M[i].x][M[i].y]){
				dp[M[i].x+dr[k]][M[i].y+dl[k]] = max(dp[M[i].x+dr[k]][M[i].y+dl[k]] , dp[M[i].x][M[i].y]+1);
				ans = max(ans , dp[M[i].x+dr[k]][M[i].y+dl[k]]);
			}
		}
	}
	cout << Name << ": " << ans+1 << endl;
}

int main(){
	int t;
	cin >> t;
	while(t--){
		initial();
		readcase();
		computing();
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值