题目1201:二叉排序树

题目描述:

    输入一系列整数,建立二叉排序数,并进行前序,中序,后序遍历。

输入:

    输入第一行包括一个整数n(1<=n<=100)。
    接下来的一行包括n个整数。

输出:

    可能有多组测试数据,对于每组数据,将题目所给数据建立一个二叉排序树,并对二叉排序树进行前序、中序和后序遍历。
    每种遍历结果输出一行。每行最后一个数据之后有一个空格。

样例输入:
5
1 6 5 9 8
样例输出:
1 6 5 9 8 
1 5 6 8 9 
5 8 9 6 1 
提示:

输入中可能有重复元素,但是输出的二叉树遍历序列中重复元素不用输出。

来源:

2005年华中科技大学计算机保研机试真题

#include<iostream>
#include<cstdio>
#include <cstdlib>
using namespace std;

struct node{
	int key;
	node *left;
	node *right;
};

void Insert(int e,node *&p){
	if(p==NULL){
		p=new node;
		p->key=e;
		p->left=NULL;
		p->right=NULL;
	}
	else if(e<p->key)
		Insert(e,p->left);
	else if(e>p->key)
		Insert(e,p->right);
	else return;	
}

node* create(int n){
	int e;
	node* p=NULL;
	while(n--){
		cin>>e;
		Insert(e,p);
	}
	return p;
}

void pre_order(node *p){
	if(p!=NULL){
		cout<<p->key<<" ";
		pre_order(p->left);
		pre_order(p->right);
	}
}

void in_order(node *p){
	if(p!=NULL){		
		in_order(p->left);
		cout<<p->key<<" ";
		in_order(p->right);
	}
}

void post_order(node *p){
	if(p!=NULL){
		post_order(p->left);		
		post_order(p->right);
		cout<<p->key<<" ";
	}
}

void Free(node *p){
	if(p!=NULL){
		Free(p->left);
		Free(p->right);
		free(p);
	}
}
int main(){
	int n;
	while(~scanf("%d",&n)){
		node *r=create(n);
		
		pre_order(r);
		cout<<endl;
		
		in_order(r);
		cout<<endl;
		
		post_order(r);
		cout<<endl;
		
		Free(r);
	} 
	return 0;
	 
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值