FZU2251OOXX--简单数学题

L - OOXX Game
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, there are N*M coins in this board with two symbol “O” or “X”. Then they take turns to choose a grid with symbol “O” and change it into “X”. The game ends when all the symbols in the board are “X”, and the one who cannot play in his (her) turns loses the game. Fat brother and Maze like this kind of OOXX game very much and play it day and night. They don’t even need a little rest after each game!

Here's the problem: Who will win the game if both use the best strategy? You can assume that Maze always goes first.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the state of the board.

1 <= T <=100, 1 <= n <=100, 1 <= m <=100

Output

For each case, output the case number first, and then output the winner’s name, either Fat brother or Maze. See the sample input and output for more details.

Sample Input

31 4OXXX2 4OOXXOOXX1 2XX

Sample Output

Case 1: MazeCase 2: Fat brotherCase 3: Fat brother
#include <iostream>
#include <stdio.h>
using namespace std;
char s[105][105];
int main()
{
    int T,n,m;
    int cnt,cas=0;
    scanf("%d",&T);
    while(T--)
    {
        cnt=0;
        cas++;
        scanf("%d%d",&n,&m);

        for(int i=0;i<n;i++)
        {
            getchar();//特别重要的地方,换行符的作用是先读入数据,另起一行读入字母时,若没有getchar(),则会读错
            for(int j=0;j<m;j++)
            {
                scanf("%c",&s[i][j]);
                if(s[i][j]=='O')
                    cnt++;
            }
        }
        if(cnt%2==1) printf("Case %d: Maze\n",cas);
        else
           printf("Case %d: Fat brother\n",cas);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值