hoj 1365 Digital Product

Given an integer N, write a program to find the minimal positive integer K such that the product of the digits of K is exactly N.

Input

There are several tests. Each test consists of an integer N(0 <= N <= 10^9) on a single line. Input is terminated by end of file.

Output

For each integer in the input, print in a single line the corresponding number K. If such a K doesn't exist, print -1 instead. No other characters are allowed in the output.

Sample Input

15
Sample Output
35

#define _CRT_SECURE_NO_WARNINGS
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int buf[10] = { 0 };
void solve(int n)
{
	if ( 0 == n || 1 == n)
	{
		if (0 == n)
			printf("%d\n", 10);
		else
			printf("%d\n", 1);
		return;
	}
	int i = 9, j;
	memset(buf, 0, sizeof(buf));
	while (i > 1)
	{
		if (0 == n % i)
		{
			buf[i]++;
			n /= i;
		}
		else
			i--;
	}
	if (n != 1)
	{
		printf("-1\n");
		return;
	}
	for (i = 2; i < 10; i++)
	{
		if (buf[i])
		{
			for (j = 0; j < buf[i]; j++)
				printf("%d", i);
		}
	}
	printf("\n");
}
int main()
{
	int n;
	while (EOF != scanf("%d", &n))
		solve(n);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值