hdu 1754 I Hate It (线段树)

Problem Description

很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。


不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
 
Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
 
Output
对于每一次询问操作,在一行里面输出最高成绩。
 
Sample Input
5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5
 
Sample Output
5
6
5
9

Author
linle


Solution

以下部分的版权归本人(小飞)所有。所有权利保留。

欢迎转载,转载时请注明出处:

http://blog.csdn.net/xiaofei_it/article/details/17173453

#include <stdio.h>
#define MAX 300000
struct Node
{
	int l,r,max;
};
int n,m,s[MAX],i,A,B;
char c;
struct Node a[MAX*10];

int max(int a,int b)
{
	if (a>b)
		return a;
	else
		return b;
}

void create(int root,int l,int r)
{
	int mid;
	a[root].l=l;a[root].r=r;
	if (l==r)
	{
		a[root].max=s[l];
		return;
	}
	mid=(l+r)/2;
	create(root*2,l,mid);
	create(root*2+1,mid+1,r);
	a[root].max=max(a[root*2].max,a[root*2+1].max);
}

int query(int r,int A,int B)
{
	int mid;
	if (B<a[r].l||a[r].r<A)
		return 0;
	if (A<=a[r].l&&a[r].r<=B)
		return a[r].max;
	return max(query(r*2,A,B),query(r*2+1,A,B));
}

void update(int r,int p)
{
	if (p<a[r].l||a[r].r<p)
		return;
	if (p==a[r].l&&p==a[r].r)
	{
		a[r].max=s[p];
		return;
	}
	update(2*r,p);
	update(2*r+1,p);
	a[r].max=max(a[r*2].max,a[r*2+1].max);
}

int main()
{
	while (scanf("%d%d",&n,&m)!=EOF)
	{
		for (i=1;i<=n;i++) scanf("%d",s+i);
		create(1,1,n);
		while (m--)
		{
			getchar();
			scanf("%c%d%d",&c,&A,&B);
			if (c=='Q')
				printf("%d\n",query(1,A,B));
			else
			{
				s[A]=B;
				update(1,A);
			}
		}
	}
	return 0;
}



 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值