POJ 1837 Balance (动态规划)

Balance
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 9425 Accepted: 5796

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.

Input

The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values.

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

Source

Romania OI 2002


题意:
有一个天平,天平上有 C 个钩子,用于钩砝码,还准备了 G 个砝码,要求将所有的砝码都挂上,但不要求所有的钩子都用上,使得天平平衡。
思路:
题目简单的说就是将天平上可能发生的状态都记录下来,再看一下刚好平衡状态时发生了几回。
容易想到的是每次需要将一个砝码放在不同的钩子上,把每次的状态记录下来。
需要注意的是状态叠加时是叠加上一个状态改变后的状态,而不需要再加上  改变后的状态  在上一个状态发生的次数,所以需要开一个二维来维护当前砝码发生的状态与前一个砝码发生的状态。(比较绕,即如下公式)
dp[j][k+hooks[i]*value[j]] += dp[j-1][k];
而非dp[j][k+hooks[i]*value[j]] += dp[j-1][k+hooks[i]*value[j]];

/*************************************************************************
	> File Name: POJ1837.cpp
	> Author: BSlin
	> Mail:  
	> Created Time: 2013年11月05日 星期二 15时14分02秒
 ************************************************************************/

#include <stdio.h>
#include <string.h>

int hooks[25],value[25],dp[25][8000];

int main() {
    //freopen("in.txt","r",stdin);
    int i, j, k, n, m, mmin, mmax,tempmin,tempmax;
    while(scanf("%d%d",&n, &m) != EOF) {
        for(i=0; i<n; i++) {
            scanf("%d",&hooks[i]);
        }
        for(i=0; i<m; i++) {
            scanf("%d",&value[i]);
        }
        memset(dp,0,sizeof(dp));
        for(i=0; i<n; i++) {
            dp[0][3750+hooks[i]*value[0]] ++;
        }
        for(j=1; j<m; j++) {
            for(i=0; i<n; i++) {
                for(k=0; k<=7500; k++) {
                    if(dp[j-1][k] != 0) {
                        dp[j][k+hooks[i]*value[j]] += dp[j-1][k];
                    }
                }
            }
        }
        printf("%d\n",dp[m-1][3750]);
    }
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值