【PAT甲级】1004 Counting Leaves (30分):DFS/BFS树的遍历

1004 Counting Leaves (30分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

      
    

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

      
    

Sample Output:

0 1

分析:BFS/DFS遍历树

输出每一层叶子节点的个数。

  • BFS:

    设置layer[]记录每层叶子节点的个数。

    节点结构体中设置lay,记录节点所在层数。每次队列push孩子节点时,更新孩子节点所在层数:Node[top].lay+1。若一个结点没有孩子节点,则是叶子,layer[该节点]++。遍历过程中,记录最深节点所在层数。

    最后输出层数个数字。

代码

  • BFS
/*BFS遍历树,数每层叶子节点的个数*/
#include<iostream>
#include<vector>
#include<queue>

using namespace std;

const int maxN=110;
const int maxM=110;
struct node {
    int lay;//所在层数(0开始)
    vector<int> child;//孩子节点
} Node[maxM];
int layer[maxM]; //每层叶子节点的个数
int N,M;
int maxLayer=0;//最深节点的层数(0开始 )

void BFS() {
    queue<int> que;
    que.push(1);//根节点

    while(!que.empty()) {
        int top=que.front();
        que.pop();
        if(Node[top].lay>maxLayer)
            maxLayer=Node[top].lay;

        bool leafFlag=true;//是否是叶子节点
        for(int i=0; i<Node[top].child.size(); i++) {
            leafFlag=false;
            int index=Node[top].child[i];
            Node[index].lay=Node[top].lay+1;
            que.push(index);
        }
        if(leafFlag)
            layer[Node[top].lay]++;
    }
}

int main() {
    fill(layer,layer+maxM,0);
    int id1,chNo,id2;
    scanf("%d%d",&N,&M);
    for(int i=0; i<M; i++) {
        scanf("%d%d",&id1,&chNo);
        for(int j=0; j<chNo; j++) {
            scanf("%d",&id2);
            Node[id1].child.push_back(id2);
        }
    }

    BFS();

    for(int i=0; i<=maxLayer; i++) {
        if(i!=0) cout<<" ";
        cout<<layer[i];
    }


    return 0;
}

  • DFS:(柳神的)
/*DFS遍历*/
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
vector<int> v[100];
int book[100], maxdepth = -1;
void dfs(int index, int depth) {
    if(v[index].size() == 0) {
        book[depth]++;
        maxdepth = max(maxdepth, depth);
        return ;
    }
    for(int i = 0; i < v[index].size(); i++)
        dfs(v[index][i], depth + 1);
}
int main() {
    int n, m, k, node, c;
    scanf("%d %d", &n, &m);
    for(int i = 0; i < m; i++) {
        scanf("%d %d",&node, &k);
        for(int j = 0; j < k; j++) {
            scanf("%d", &c);
            v[node].push_back(c);
        }
    }
    dfs(1, 0);
    printf("%d", book[0]);
    for(int i = 1; i <= maxdepth; i++)
        printf(" %d", book[i]);
    return 0;
}

测试数据:

1491599-20200216150625009-2093127977.png

6 3
01 2 02 05
02 2 03 04
05 1 06
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值