九度OJ题目1144:Freckles

题目描述:

    In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through. 
    Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle. 

输入:

    The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.

输出:

    Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.

样例输入:
3
1.0 1.0
2.0 2.0
2.0 4.0
样例输出:
3.41
来源:

2009年北京大学计算机研究生机试真题

#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;

int tree[101];
struct edge{
    int u,v;
    double w;
    bool operator < (const edge &A)const{
        return w<A.w;
    }
}E[6000];

struct Point{
    double x,y;
    double getd(Point A){
        return sqrt((x-A.x)*(x-A.x)+(y-A.y)*(y-A.y));
    }
}p[101];

int findRoot(int x){
    if(tree[x]==-1) return x;
    else{
        int tmp=findRoot(tree[x]);
        tree[x]=tmp;
        return tmp;
    }
}

int main(){
    int n;
    while(scanf("%d",&n)==1&&n){
        for(int i=1;i<=n;i++) scanf("%lf%lf",&p[i].x,&p[i].y);
        int num=0;
        for(int i=1;i<=n;i++)
            for(int j=i+1;j<=n;j++){
                E[num].u=i;
                E[num].v=j;
                E[num].w=p[i].getd(p[j]);
                num++;
            }
        sort(E,E+num);
        for(int i=1;i<=n;i++) tree[i]=-1;
        double ans=0;
        for(int i=0;i<num;i++){
            int a=findRoot(E[i].u);
            int b=findRoot(E[i].v);
            if(a!=b){
                tree[a]=b;
                ans+=E[i].w;
            }
        }
        printf("%.2f\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ykycode

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值