PAT (Basic Level) Practise (中文)1030. 完美数列(25)

1030. 完美数列(25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CAO, Peng

给定一个正整数数列,和正整数p,设这个数列中的最大值是M,最小值是m,如果M <= m * p,则称这个数列是完美数列。

现在给定参数p和一些正整数,请你从中选择尽可能多的数构成一个完美数列。

输入格式:

输入第一行给出两个正整数N和p,其中N(<= 105)是输入的正整数的个数,p(<= 109)是给定的参数。第二行给出N个正整数,每个数不超过109

输出格式:

在一行中输出最多可以选择多少个数可以用它们组成一个完美数列。

输入样例:
10 8
2 3 20 4 5 1 6 7 8 9
输出样例:

8

#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn=1e5+10;
int a[maxn],n,p;

int main(){
    scanf("%d%d",&n,&p);
    for(int i=0;i<n;i++) scanf("%d",&a[i]);
    sort(a,a+n);
    int ans=1;
    for(int i=0;i<n;i++){
        int j=upper_bound(a+i+1,a+n,(long long)a[i]*p)-a;
        ans=max(ans,j-i);
    }
    printf("%d\n",ans);
    return 0;
}
#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn=1e5+10;
int a[maxn],n,p;

int main(){
    scanf("%d%d",&n,&p);
    for(int i=0;i<n;i++) scanf("%d",&a[i]);
    sort(a,a+n);
    int i=0,j=0,cnt=1;
    while(i<n&&j<n){
        while(j<n&&a[j]<=(long long)a[i]*p){
            cnt=max(cnt,j-i+1);
            j++;
        }
        i++;
    }
    printf("%d",cnt);
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ykycode

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值