PAT (Advanced Level) Practise 1017. Queueing at Bank (25)

1017. Queueing at Bank (25)

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2
代码:
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

const int k=105;
const int inf=1e9;
struct Customer{
    int comeTime,serveTime;
}newCustomer;

vector<Customer> custom;

int convertTime(int h,int m,int s){
    return h*3600+m*60+s;
}

bool cmp(Customer a,Customer b){
    return a.comeTime<b.comeTime;
}

int endTime[k];

int main(){
    int c,w,totTime=0;
    int stTime=convertTime(8,0,0);
    int edTime=convertTime(17,0,0);
    scanf("%d%d",&c,&w);
    for(int i=0;i<w;i++) endTime[i]=stTime;
    for(int i=0;i<c;i++){
        int h,m,s,serveTime;
        scanf("%d:%d:%d %d",&h,&m,&s,&serveTime);
        int comeTime=convertTime(h,m,s);
        if(comeTime>edTime) continue;
        newCustomer.comeTime=comeTime;
        newCustomer.serveTime=serveTime<=60?serveTime*60:3600;
        custom.push_back(newCustomer);
    }
    sort(custom.begin(),custom.end(),cmp);
    for(int i=0;i<custom.size();i++){
        int idx=-1,minEndTime=inf;
        for(int j=0;j<w;j++){
            if(endTime[j]<minEndTime){
                minEndTime=endTime[j];
                idx=j;
            }
        }
        if(endTime[idx]<=custom[i].comeTime) endTime[idx]=custom[i].comeTime+custom[i].serveTime;
        else{
            totTime+=endTime[idx]-custom[i].comeTime;
            endTime[idx]+=custom[i].serveTime;
        }
    }
    if(custom.size()==0) printf("0.0");
    else printf("%.1f",totTime/60.0/custom.size());
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ykycode

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值