hdu 3709 Balanced Number

Balanced Number

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1877    Accepted Submission(s): 840


Problem Description
A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job
to calculate the number of balanced numbers in a given range [x, y].
 

Input
The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10 18).
 

Output
For each case, print the number of balanced numbers in the range [x, y] in a line.
 

Sample Input
  
  
2 0 9 7604 24324
 

Sample Output
  
  
10 897

题意是定义一个平衡数,这个数满足选取某一位为轴左右两边力矩和为0,求区间中这种数的个数。

还是功力不够,想了半天没想到如何递归子状态,看了别人报告才明白,枚举轴的位置就行了,顿时觉得如此简单,再就是最后全0的情况重复判断wrong了几次。。继续修炼吧!!!


#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

#define LL long long
int p[25];
LL dp[25][25][3000];
LL dfs(int h,int cen,int s,bool sign){
	if(h<0) {
		if(s==0) return 1;
		return 0;
	}
	if(!sign && dp[h][cen][s]!=-1) return dp[h][cen][s];
	LL ans = 0;
	int end = sign?p[h]:9;
	for(int i=0;i<=end;i++){
		ans += dfs(h-1,cen,s+(h-cen)*i,sign && i==p[h]);
	}
	if(!sign) dp[h][cen][s] = ans;
	return ans;
}
LL solve(LL n){
	int cnt = 0;
	if(n==-1) return 0;
	while(n>0){
		p[cnt++] = n%10;
		n /= 10;
	}
	LL ans = 0;
	for(int i=0;i<cnt;i++){
		ans += dfs(cnt-1,i,0,true);
	}
	return ans-cnt+1;
}
int main(){
	int T;
	memset(dp,-1,sizeof dp);
	cin >> T;
	LL L,R;
	while(T--){
		cin >> L >> R;
		cout << solve(R) - solve(L-1) <<endl;
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值