HDU 3709 Balanced Number

A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job 
to calculate the number of balanced numbers in a given range [x, y].
Input
The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10  18).
Output
For each case, print the number of balanced numbers in the range [x, y] in a line.
Sample Input
2
0 9
7604 24324

Sample Output

10

一个数,选一个数位为支点,如果两边的数分别用数值乘以离支点的距离的和相等则为平衡数,如abcd若a*1=c*1+d*2则为平衡树,支点可以任一选,若0=b*1+c*2+d*3,也是平衡数

可以先算出y以内的平衡数然后减去x-1内的平衡数 

首先枚举支点,然后枚举数位

数位dp

#include<bits\stdc++.h>
using namespace std;

typedef long long ll;
ll dp[20][20][2005];
ll a[20];
ll dfs(ll pos,ll o,ll s,ll lim)//当前数位,当前的支点,当前位置左边比右边重s,当前位是否达到了最大值
{
    if(pos==-1)
        return s==0;
    if(s<0) return 0;//如果此时的左边的重量小于右边,则直接跳过,因为是从左往右计算
    if(!lim&&dp[pos][o][s]!=-1)
        return dp[pos][o][s];
    ll ans=0;
    int up=lim?a[pos]:9;
    for(ll i=0;i<=up;i++)
    {
        ans+=dfs(pos-1,o,s+(pos-o)*i,lim&&i==up);
    }
    if(!lim) dp[pos][o][s]=ans;
    return ans;
}
ll solve(ll n)
{
    int i=0;
    while(n)
    {
        a[i++]=n%10;
        n/=10;
    }
    ll ans=0;
    for(int j=0;j<i;j++)//枚举每一个支点
        ans+=dfs(i-1,j,0,1);
    return ans-(i-1);
}
int main()
{
    int t;
    scanf("%d",&t);
    memset(dp,-1,sizeof(dp));
    while(t--)
    {
        ll n,m;
        scanf("%I64d%I64d",&n,&m);
        printf("%I64d\n",solve(m)-solve(n-1));
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值