3835. 计算三角形的周长

3835. 计算三角形的周长

Constraints

Time Limit: 1 secs, Memory Limit: 256 MB

Description

在平面直角坐标系中,给出三角形三个顶点的坐标,求三角形的周长.

Input

第一行是一个整数T,表示总共有T组数据.

接下来的T行,每行有6个实数x1, y1, x2, y2, x3, y3,表示三角形三个顶点的坐标.

Output

每行输出一个三角形的周长,小数点后保留5位数字.

Sample Input

2
0 0 0 3 4 0
1.2 5.5 -1.0 -4.7 3.2 -0.8

Sample Output

12.00000
22.77589

Problem Source

林瀚


自己画个图就好了。用了<math.h>头文件。

代码如下:

#include <iostream>
#include <stdio.h>
#include <math.h>

using namespace std;

int main () {
	int T;
	cin>>T;
	while (T--) {
		double a, b, c, d, e, f;
		cin>>a>>b>>c>>d>>e>>f;
		double l;
		l = sqrt(pow(a-c,2)+pow(b-d,2))+sqrt(pow(a-e,2)+pow(b-f,2))+sqrt(pow(c-e,2)+pow(d-f,2));
		printf("%0.5f\n", l);
	}
	
	//system("pause");
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值