1623. Sixth Grade Math 求最大公约数和最小公倍数的

1623. Sixth Grade Math

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

In sixth grade, students are presented with different ways to calculate the Least Common Multiple (LCM) and the Greatest Common Factor (GCF) of two integers. The LCM of two integers a and b is the smallest positive integer that is a multiple of both a and b . The GCFof two non-zero integers a and b is the largest positive integer that divides both a and bwithout remainder.

Input

The first line of input contains a single integer N , (1≤N≤1000) which is the number of data sets that follow. Each data set consists of a single line of input containing two positive integers, a and b , (1≤ab≤1000) separated by a space.

Output

For each data set, you should generate one line of output with the following values: The data set number as a decimal integer (start counting at one), a space, the LCM, a space, and the GCF.

Sample Input

3 
5 10 
7 23 
42 56

Sample Output

1 10 5 
2 161 1 
3 168 14

#include <iostream>
#include <algorithm>

using namespace std;

int GCF(int a,int b){
	int temp;
	if (a < b){  /*交换两个数,使大数放在a上*/        
		swap(a, b);
	}
	while(b!=0){ /*利用辗除法,直到b为0为止*/        
		temp = a % b;
		a = b;
		b = temp;
	}
	return a;
}

int LCM (int a, int b) {
	return a * b / GCF(a, b);
}


int main () {
	int T;
	cin >> T;
	int n = 1;
	while (T--) {
		int a, b;
		cin >> a >> b;
		cout << n <<' '<< LCM(a, b) <<' '<<GCF(a, b)<<endl;
		n++;
	}
	//system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值