HDU 2819解题报告

Swap

                                               Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                       Total Submission(s): 1710    Accepted Submission(s): 572
                                                                                                          Special Judge


Problem Description
Given an N*N matrix with each entry equal to 0 or 1. You can swap any two rows or any two columns. Can you find a way to make all the diagonal entries equal to 1?
 

Input
There are several test cases in the input. The first line of each test case is an integer N (1 <= N <= 100). Then N lines follow, each contains N numbers (0 or 1), separating by space, indicating the N*N matrix.
 

Output
For each test case, the first line contain the number of swaps M. Then M lines follow, whose format is “R a b” or “C a b”, indicating swapping the row a and row b, or swapping the column a and column b. (1 <= a, b <= N). Any correct answer will be accepted, but M should be more than 1000.

If it is impossible to make all the diagonal entries equal to 1, output only one one containing “-1”. 
 

Sample Input
  
  
2 0 1 1 0 2 1 0 1 0
 

Sample Output
  
  
1 R 1 2 -1
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   2818  2821  2817  2825  2824 

       这道题最终是要保证主对角线上的数都为1。我们可以想到通过行列匹配的建图方法进行构建。保证一个行只有一个列为1。进行匹配以后要对match数组进行排序,通过选择排序从而打印出移动的步骤。

        本题较难。

       

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<vector>
#include<cstring>
#define pb push_back
#define CLR(x) memset(x,0,sizeof(x))
#define __CLR(x) memset(x,-1,sizeof(x))
using namespace std;

int n;
int a[110][110];
int match[110];
bool vis[110];
vector<int>G[110];
int p1[110],p2[110];

bool dfs(int u)
{
    for(int i=0; i<G[u].size(); i++)
    {
        int t=G[u][i];
        if(!vis[t])
        {
            vis[t]=1;
            if(match[t]==-1||dfs(match[t]))
            {
                match[t]=u;
                return true;
            }
        }
    }
    return false;
}

int main()
{
    
    while(~scanf("%d",&n))
    {
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
            {
                scanf("%d",&a[i][j]);
                if(a[i][j]==1)
                    G[i].pb(j);
            }
        __CLR(match);
        int num=0;
        for(int i=1; i<=n; i++)
        {
            CLR(vis);
            if(dfs(i))
                num++;
        }
        if(num!=n) printf("-1\n");
        else
        {
            int cnt=0;
            CLR(p1);
            CLR(p2);
            for(int i=1; i<=n; i++)
            {
                int k=i;
                for(int j=i; j<=n; j++)
                {
                    if(match[j]<match[k])
                        k=j;
                }
                if(k!=i)
                {
                    cnt++;
                    p1[cnt]=i,p2[cnt]=k;
                    swap(match[i],match[k]);
                }
            }
            printf("%d\n",cnt);
            for(int i=1; i<=cnt; i++)
                printf("C %d %d\n",p1[i],p2[i]);
        }
        for(int i=0; i<110; i++)
            G[i].clear();
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值