poj2661-取对数

Factstone Benchmark

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5042 Accepted: 2360

Description
Amtel has announced that it will release a 128-bit computer chip by 2010, a 256-bit computer by 2020, and so on, continuing its strategy of doubling the word-size every ten years. (Amtel released a 64-bit computer in 2000, a 32-bit computer in 1990, a 16-bit computer in 1980, an 8-bit computer in 1970, and a 4-bit computer, its first, in 1960.)
Amtel will use a new benchmark - the Factstone - to advertise the vastly improved capacity of its new chips. The Factstone rating is defined to be the largest integer n such that n! can be represented as an unsigned integer in a computer word.
Given a year 1960 <= y <= 2160, what will be the Factstone rating of Amtel’s most recently released chip?

Input
There are several test cases. For each test case, there is one line of input containing y. A line containing 0 follows the last test case.

Output
For each test case, output a line giving the Factstone rating.

Sample Input

1960
1981
0

Sample Output

3
8

简单来说,就是给一个n,找到一个最大的k,满足
2^n>k!

先贴ac代码

#include <stdio.h>
#include <stdlib.h>
#include <math.h>

int main()
{
	int y=0;
	int isquit = 0;
	int n=1,t=0;
	int nn=1;
	int i=0;
	
	int bits=0;
	double temp=0;  //float不行,double可以
	
	while(!isquit)
	{
		scanf("%d",&y);
		
		if(0 == y)
		{
			break;
		}
		
		y/=10;
		y*=10;
		
		t=(y-1960)/10;   //4*2^t
		bits=pow(2,t)*4;
		
		temp=0;
		n=1;
		while((int)temp<bits)
		{
			temp+=(log(n)/log(2));
			n++;
		}
		
		printf("%d\n",n-2);
		
	}
	
	return 0;
}

方法:
2^n > k!

n * log 2 > log 2 + log 3 + …+ log k

再两边同除 log 2 就可以了。

自己跳的坑:
这里取得log2,因为这样就只用给temp取对数。然而这样temp的必须用double,用float会导致明显的误差,用2160测试结果差了5,用int型的temp更是结果差了几万。不过看网上代码,如果两个都用log10的话,用float精度也可以ac。

关于float误差控制,可以参考这篇文章:

https://www.cnblogs.com/ziyu-trip/p/8168881.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值