Fibonacci
Problem Description
2007年到来了。经过2006年一年的修炼,数学神童zouyu终于把0到100000000的Fibonacci数列
(f[0]=0,f[1]=1;f[i] = f[i-1]+f[i-2](i>=2))的值全部给背了下来。
接下来,CodeStar决定要考考他,于是每问他一个数字,他就要把答案说出来,不过有的数字太长了。所以规定超过4位的只要说出前4位就可以了,可是CodeStar自己又记不住。于是他决定编写一个程序来测验zouyu说的是否正确。
Input
输入若干数字n(0 <= n <= 100000000),每个数字一行。读到文件尾。
Output
输出f[n]的前4个数字(若不足4个数字,就全部输出)。
Sample Input
0
1
2
3
4
5
35
36
37
38
39
40
Sample Output
0
1
1
2
3
5
9227
1493
2415
3908
6324
1023
题意:输出Fibonacci数组的前四位,n<=100000000;
思路:看到这个题的数据范围,0(n)的时间复杂度是不行的,想是不是有循环节,但是前四位的是跟后面几位有关系的(可以产生进位),不能只存前四位;然后Fibonacci数肯定有公式可以求得,上网搜了下
公式如下:
先看对数的性质,loga(b^c)=c*loga(b),loga(b*c)=loga(b)+loga(c);
这题要利用到数列的公式:an=(1/√5) * [((1+√5)/2)^n-((1-√5)/2)^n](n=1,2,3.....)
取完对数
代码:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
|
#include <cstdlib>
#include <iostream>
#include <cmath>
using
namespace
std;
const
double
f=(sqrt(5.0)+1)/2.0;
int
fac[21]={0,1,1};
void
fincc()
{
for
(
int
i=3;i<=20;i++)
fac[i]=fac[i-1]+fac[i-2];
}
int
main(
int
argc,
char
*argv[])
{
int
n;
fincc();
while
(scanf(
"%d"
,&n)!=EOF)
{
// puts("bug");
if
(n<=20) { printf(
"%d\n"
,fac[n]);
continue
;}
double
ans=-0.5*log(5.0)/log(10.0)+n*log(f)/log(10.0);
ans = ans-floor(ans);
ans=pow(10.0,ans);
int
ans1=
int
(ans*1000);
printf(
"%d\n"
,ans1);
}
system(
"PAUSE"
);
return
EXIT_SUCCESS;
}
|