HDU 1312 Red and Black

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

 

 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

 

 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

 

 

Sample Input

 

6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0

 

 

Sample Output

 

45 59 6

13

思路:DFS,如果本题还要搜代码,说明你就是新手了,那么我好好地解释下吧!你可以标记本题的初始位置,从初始位置开始往4个方向搜索,找到一个‘.’就覆盖一个点,并统计上它,这样就很简单了!

AC代码:

#include<stdio.h>
#include<string.h>
#define N 25
char str[N][N];
int dir[4][2]={1,0, -1,0, 0,1 , 0,-1};  //四个方向
int n,m,ans;
void dfs(int a,int b)
{
    ans++;          //统计点
    str[a][b]='#';  //覆盖点
    for(int i=0;i<4;i++)    //往四个方向搜索
    {
        int x=a+dir[i][0];
        int y=b+dir[i][1];
        if(x>=0&&y>=0&&x<m&&y<n&&str[x][y]=='.')
            dfs(x,y);
    }
}
int main()
{
    int si,sj,i,j;
    while(~scanf("%d %d",&n,&m))
    {
        if(n==0&&m==0)
            break;
        ans=0;
        for(i=0;i<m;i++)
        {
            getchar();      //回车的吸收  一定要注意!
            for(j=0;j<n;j++)
            {
                scanf("%c",&str[i][j]);
                if(str[i][j]=='@')
                {
                    si=i;
                    sj=j;
                }
            }
        }
        dfs(si,sj);
        printf("%d\n",ans);
    }
    return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值