xmu 1009

Description

Butchering Farmer John's cows always yields the best prime rib. You can tell prime ribs by looking at the digits lovingly stamped across them, one by one, by FJ and the USDA. Farmer John ensures that a purchaser of his prime ribs gets really prime ribs because when sliced from the right, the numbers on the ribs continue to stay prime right down to the last rib, e.g.:

7 3 3 1

The set of ribs denoted by 7331 is prime; the three ribs 733 are prime; the two ribs 73 are prime, and, of course, the last rib, 7, is prime. The number 7331 is called a superprime of length 4.

Write a program that accepts a number N 1 <=N<=8 of ribs and prints all the superprimes of that length.

The number 1 (by itself) is not a prime number.

Input

A single line with the number N.

Output

The superprime ribs of length N, printed in ascending order one per line.

Sample Input

4

Sample Output

2333
2339
2393
2399
2939
3119
3137
3733
3739
3793
3797
5939
7193
7331
7333
7393

Source
USACO

 

这道题目就是按照题意一步一步的生成就可以了。

第一位只能是2,3,5,7。

之后的每一位只能是1,3,7,9。

如果当前的num是满足条件的superprime,则依次检验num*10+1,num*10+3,num*10+7,num*10+9 是否也为质数,重复此步骤知道指定数位

#include<stdio.h>
#include<math.h>
int b[5]={0,2,3,5,7},a[5]={0,1,3,7,9};
int c[9]={0,1,10,100,1000,10000,100000,1000000,10000000},k;
int isprime (int s)
{
	 int l=(double)sqrt(s);
	for(int i=3;i<=l;i+=2)
		if(s%i==0) return 0;
	return 1;
}
void prime(int s)
{
	if(s>k)
		printf("%d\n",s);
	else
	{
		int i;
		s*=10;
		for(i=1;i<=4;i++)
		{
			s+=a[i];
		if(isprime(s)) prime(s);
		 s-=a[i];
		}
	}
}
int main()
{
	int i,s,m;
	scanf("%d",&m);
	k=c[m];
	for(i=1;i<=4;i++)
	{
		s=b[i];
		prime(s);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值