xmu 1010


Description

Consider the number triangle shown below. Write a program that calculates the highest sum of numbers that can be passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

In the sample above, the route from 7 to 3 to 8 to 7 to 5 produces the highest sum: 30.

Input

The first line contains R (1 <= R <= 1000), the number of rows. Each subsequent line contains the integers for that particular row of the triangle. All the supplied integers are non-negative and no larger than 100.

Output

A single line containing the largest sum using the traversal specified.

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Huge input, scanf is recommended if you are using C++.

 

如果从数字堆的顶部出发,那么每次都有两个选择(无法用贪心),要一个个的试验一次,那么时间的复杂度是O(2^k),k为数字堆的层数。换一种思路,如果从底部出发,每次都选上层相邻比较大的数跟自己相加,这种的贪心策略可以保证结果的真确性,而且复杂度为O(k^2),k为数字堆的层数。

 

#include <stdio.h>
#define maxn 1005
int  v[maxn][maxn];
int main()
{
	int n;
	int i, j;
	long temp;
	
	scanf("%d", &n);
	for (i=0; i<n; i++)
	{
		for (j=0; j<i+1; j++)
		{
			scanf("%ld", &v[i][j]);
		}
	}
	for (i=n-2; i>=0; i--)
	{
		for (j=0; j<=i; j++)
		{
			temp = v[i+1][j]>v[i+1][j+1] ? v[i+1][j]:v[i+1][j+1];
			v[i][j] += temp;
		}
	}
	printf("%ld\n", v[0][0]);
	return 0;
}


 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值