POJ-1050(HDU-1081) To the Max

86 篇文章 0 订阅
69 篇文章 0 订阅
To the Max
Time Limit: 1000MS Memory Limit: 10000K
   

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source

Greater New York 2001

————————————————————赶时间的分割线————————————————————

思路:以前做过一维的最大连续子序列「参见博客」,用了贪心的方法。这次扩展到二维,我们来分析一下。

类比一维的做法。当时时间复杂度降到了O(n)很漂亮,方法是把一维降维,变成一个数字。从左至右进行贪心,一旦sum加上该数比该数还小,或者说sum变成负的了,那么果断丢弃这个区间,它不可能是最优解。

现在二维了,需要降维成一维的。一个矩阵分割成一行一行的,每一行的总和当成一个数,那么从第一行到最后一行,就是竖着的“最大连续子序列”。那么所分割的这一行一行该怎么决定呢?……没有办法你就枚举吧。整张图是n*n,复杂度至少要O(n^2),用上O(n)的贪心,就是O(n^3)了。

核心如下:

一维:
for i ~ n-1
    if(sum > 0)
        sum += a;
    else
        sum = a;
    if(sum > best)
        best = sum;
代码如下:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#define A (sum[i][e] - sum[i][s-1])
const int N = 105;
int sum[N][N];
const int IMP = -1000;

int main()
{
    int n, ans, best;
    while(~scanf("%d", &n)) {
        best = IMP;
        for(int i = 1; i <= n; i++) {
            for(int j = 1; j <= n; j++) {
                scanf("%d", &sum[i][j]);
                sum[i][j] += sum[i][j-1];//只需按行存前缀和
            }
        }
        for(int s = 1; s <= n; s++) {
            for(int e = s; e <= n; e++) {//枚举每行起点和终点
                ans = 0;//注意!
                for(int i = 1; i <= n; i++) {
                    if(ans > 0)
                        ans += A;//终点减去起点前面的,就是区间和
                    else
                        ans = A;
                    if(ans > best)
                        best = ans;
                }
            }
        }
        printf("%d\n", best);
    }
    return 0;
}


  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值