POJ--1050--To the Max(线性动规,最大子矩阵和)

To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 44723 Accepted: 23679
Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.
Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output

Output the sum of the maximal sub-rectangle.
Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1

8 0 -2
Sample Output

15

这道题目是hdu1003 的升级版,HDU 1003,是一维数组最长子段和的问题,这个题目扩展到二维,思路就是把二维转换成一维,
先求第一行最大子段和,再求第一行跟第二行合起来的最大子段和,再求第一行到第三行合起来的最大值,实际上就是把二维数组转换成一维的了,

#include <iostream>
#include <math.h>
#include <string.h>
#include <algorithm>
#include <stdlib.h>

using namespace std;
int a[105][105];
int n;
int dp[105];
int b[105];
int sum;
int main()
{
   while(scanf("%d",&n)!=EOF)
   {
       sum=0;
       for(int i=1;i<=n;i++)
       {
           for(int j=1;j<=n;j++)
           {
               scanf("%d",&a[i][j]);
           }
       }
       for(int i=1;i<=n;i++)
       {
           memset(b,0,sizeof(b));
           memset(dp,0,sizeof(dp));
           for(int k=i;k<=n;k++)
           {
               for(int j=1;j<=n;j++)
               {
                   b[j]+=a[k][j];
                   if(dp[j-1]>=0)
                       dp[j]=dp[j-1]+b[j];
                   else
                       dp[j]=b[j];
                   if(sum<dp[j])
                       sum=dp[j];
               }
           }

       }
       printf("%d\n",sum);

   }
    return 0;
}

转载于:https://www.cnblogs.com/dacc123/p/8228846.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值