ZOJ-1360(POJ-1328) Radar Installation

26 篇文章 0 订阅
12 篇文章 0 订阅
Radar Installation

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Input

The input consists of several test cases. The first line of each case contains two integers n (1 n 1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros.


Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.


Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0


Sample Output

Case 1: 2
Case 2: 1


Source:  Asia 2002, Beijing (Mainland China)

————————————————————饥饿的分割线————————————————————
思路:一开始我的思路是自左至右尽量将雷达向右放,但是这么贪心是不对的。例如这组数据:
 4 5
-5 3
-3 5
 2 3
 3 3
答案是2。因为雷达放在[-3, 5]的正下方比放在[-5, 3]允许(安放雷达)的最右点更优。
那么转变思路。【--_--其实我是去看题解了……】
一个雷达能够覆盖一个岛屿当且仅当岛屿处于雷达范围内。但是雷达的位置不确定。不要紧,岛屿是确定的。岛屿能够被雷达覆盖,当且仅当“雷达处于岛屿范围内”。也就是说,岛屿允许的最左点和岛屿允许的最右点之间只要有一个雷达,岛屿就被覆盖了。那么要想让雷达尽量少,就要将雷达尽量放在重叠区间内。
所以将所有岛屿的坐标转化成区间。重叠的区间个数就是最少的雷达个数。这其实就是选择不相交区间问题。
友情提示:注意使用double。
代码如下:
/****************************************/
 #include <cstdio>
 #include <cstdlib>
 #include <cstring>
 #include <algorithm>
 #include <cmath>
 #include <stack>
 #include <queue>
 #include <vector>
 #include <map>
 #include <string>
 #include <iostream>
 using namespace std;
/****************************************/
struct Node
{
	double left, right;
}a[1010];

bool cmp(Node a, Node b)
{
	if(a.right != b.right)
		return a.right < b.right;
	return a.left < b. left;
}

int main()
{
	int n, d, cas = 1;
	//freopen("rader.in", "r", stdin);
	while(~scanf("%d%d", &n, &d), n||d) {
		int maxi = -1, x, y;
		for(int i = 0; i < n; i++) {
			scanf("%d%d", &x, &y);
			a[i].left = x - sqrt((double)d*d - y*y);
			a[i].right = x + sqrt((double)d*d - y*y);
			maxi = max(maxi, y);
		}
		printf("Case %d: ", cas++);
		if(maxi > d) {
			printf("-1\n");
		}
		else {
			sort(a, a+n, cmp);
			int ans = 1;
			for(int i = 0, j = 1; j < n; j++) {
				if(a[j].left > a[i].right) {
					ans++;
					i = j;
				}
			}
			printf("%d\n", ans);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值