USACO-cha1-sec1.4 Arithmetic Progressions

Arithmetic Progressions

An arithmetic progression is a sequence of the form a, a+b, a+2b, ..., a+nb where n=0,1,2,3,... . For this problem, a is a non-negative integer and b is a positive integer.

Write a program that finds all arithmetic progressions of length n in the set S of bisquares. The set of bisquares is defined as the set of all integers of the form p2 + q2 (where p and q are non-negative integers).

TIME LIMIT: 5 secs

PROGRAM NAME: ariprog

INPUT FORMAT

Line 1:N (3 <= N <= 25), the length of progressions for which to search
Line 2:M (1 <= M <= 250), an upper bound to limit the search to the bisquares with 0 <= p,q <= M.

SAMPLE INPUT (file ariprog.in)

5
7

OUTPUT FORMAT

If no sequence is found, a singe line reading `NONE'. Otherwise, output one or more lines, each with two integers: the first element in a found sequence and the difference between consecutive elements in the same sequence. The lines should be ordered with smallest-difference sequences first and smallest starting number within those sequences first.

There will be no more than 10,000 sequences.

SAMPLE OUTPUT (file ariprog.out)

1 4
37 4
2 8
29 8
1 12
5 12
13 12
17 12
5 20
2 24

————————————————————口渴的分割线————————————————————

前言:这题还是蛮简单的。数据范围小可以直接暴搜。但是如果不注意剪枝是不行的。

思路:既然全部都是用p^2+q^2得到的结果构成的等差数列,那么开一个vis数组就行了。经过计算剪枝是这样的:

d(公差) <= 2*m*m/(len-1)

a1(首项) <= 2*m*m - d*(len-1)

代码如下:

/*
ID: j.sure.1
PROG: ariprog
LANG: C++
*/
/****************************************/
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <string>
#include <iostream>
using namespace std;
/****************************************/
bool vis[1000000];
int len, m;
struct Node
{
	int d;
	int a1;
}ans[1000000];

int main()
{
	freopen("ariprog.in", "r", stdin);
	freopen("ariprog.out", "w", stdout);
	scanf("%d%d", &len, &m);
	for(int i = 0; i <= m; i++)
	for(int j = i; j <= m; j++) {
		vis[i*i + j*j] = true;
	}
	int cas = 0;
	for(int d = 1; d <= 2*m*m/(len-1); d++) {
		for(int a1 = 0; a1 <= 2*m*m - d*(len-1); a1++) 
			if(vis[a1]) {
			for(int l = 1; l < len; l++) {
				int u = a1 + l*d;
				if(vis[u]) {
					if(l == len-1) {
						cas++;
						ans[cas].d = d;
						ans[cas].a1 = a1;
					}
				}
				else {
					break;
				}
			}
		}
	}
	if(!cas)
		puts("NONE");
	else
	for(int i = 1; i <= cas; i++) {
		printf("%d %d\n", ans[i].a1, ans[i].d);
	}
	fclose(stdin);
	fclose(stdout);
	return 0;
}
	


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值