USACO Arithmetic Progressions

Arithmetic Progressions

An arithmetic progression is a sequence of the form a, a+b, a+2b, ..., a+nb where n=0,1,2,3,... . For this problem, a is a non-negative integer and b is a positive integer.

Write a program that finds all arithmetic progressions of length n in the set S of bisquares. The set of bisquares is defined as the set of all integers of the form p2 + q2 (where p and q are non-negative integers).

TIME LIMIT: 5 secs

PROGRAM NAME: ariprog

INPUT FORMAT

Line 1:N (3 <= N <= 25), the length of progressions for which to search
Line 2:M (1 <= M <= 250), an upper bound to limit the search to the bisquares with 0 <= p,q <= M.

SAMPLE INPUT (file ariprog.in)

5
7

OUTPUT FORMAT

If no sequence is found, a singe line reading `NONE'. Otherwise, output one or more lines, each with two integers: the first element in a found sequence and the difference between consecutive elements in the same sequence. The lines should be ordered with smallest-difference sequences first and smallest starting number within those sequences first.

There will be no more than 10,000 sequences.

SAMPLE OUTPUT (file ariprog.out)

1 4
37 4
2 8
29 8
1 12
5 12
13 12
17 12
5 20
2 24


Submission file Name:   
USACO Gateway  |    Comment or Question






/*
    ID:qhn9992
    PROG:ariprog
    LANG:C++11
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <set>
#include <algorithm>

using namespace  std;

int vis[130000];
bool vd[130000];
int vvv[130000];
int n,m,cnt,cnt2,cnt3;
int dist[130000];
struct node
{
    int a,b;
};
node ans[13000];
bool cmp(node x,node y)
{
    return (x.b!=y.b) ? (x.b<y.b) : (x.a<y.a) ;
}
int main()
{
    freopen("ariprog.in","r",stdin);
    freopen("ariprog.out","w",stdout);
    scanf("%d%d",&n,&m);
    for(int i=0;i<=m;i++) for(int j=0;j<=m;j++) { vis[i*i+j*j]=1; if(i<=j) vvv[cnt3++]=i*i+j*j; }
    sort(vvv,vvv+cnt3);
    int last=0;vd[0]=1;
    for(int i=0;i<cnt3;i++)
    {
        for(int j=i+1;j<cnt3;j++)
        {
            int d=vvv[j]-vvv[i];
            if(vd[d]==0)
            {
                vd[d]=1;
                dist[cnt++]=d;
            }
        }
    }
    sort(dist,dist+cnt);
    for(int i=0;i<2*m*m+10;i++)
    {
        if(vis[i])
        {
            for(int j=0;j<cnt;j++)
            {
            if(i+(n-1)*dist[j]>2*m*m) break;
            if(vis[i+min(n,1)*dist[j]]&&vis[i+(n-1)*dist[j]]&&vis[i+((n-1)/2)*dist[j]]&&vis[i+((n-1)*2/3)*dist[j]]&&vis[i+((n-1)/3)*dist[j]]&&vis[i+((n-1)/4)*dist[j]])
            {
                bool flag=true;
                for(int k=n-1;k>=1;k--)
                {
                    if(vis[i+k*dist[j]]==0)
                    {
                        flag=false; break;
                    }
                }
                if(flag)
                {
                    ans[cnt2++]=(node){i,dist[j]};
                }
            }
            }
        }
    }
    if(cnt2==0)
    {
        puts("NONE");
        return 0;
    }
    sort(ans,ans+cnt2,cmp);
    for(int i=0;i<cnt2;i++)
    {
        printf("%d %d\n",ans[i].a,ans[i].b);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值