POJ-3363 Annoying painting tool

Annoying painting tool
Time Limit: 1000MS Memory Limit: 65536K

Description

Maybe you wonder what an annoying painting tool is? First of all, the painting tool we speak of supports only black and white. Therefore, a picture consists of a rectangular area of pixels, which are either black or white. Second, there is only one operation how to change the colour of pixels:

Select a rectangular area of r rows and c columns of pixels, which is completely inside the picture. As a result of the operation, each pixel inside the selected rectangle changes its colour (from black to white, or from white to black).

Initially, all pixels are white. To create a picture, the operation described above can be applied several times. Can you paint a certain picture which you have in mind?

Input

The input contains several test cases. Each test case starts with one line containing four integers n, m, r and c. (1 ≤ r ≤ n ≤ 100, 1 ≤ c ≤ m ≤ 100), The following n lines each describe one row of pixels of the painting you want to create. The ith line consists of m characters describing the desired pixel values of the ith row in the finished painting ('0' indicates white, '1' indicates black).

The last test case is followed by a line containing four zeros.

Output

For each test case, print the minimum number of operations needed to create the painting, or -1 if it is impossible.

Sample Input

3 3 1 1
010
101
010
4 3 2 1
011
110
011
110
3 4 2 2
0110
0111
0000
0 0 0 0

Sample Output

4
6
-1

————————————————————尴尬的分割线————————————————————

前言:许久之前的代码了,但是不知道为什么没有发题解。。。补上

思路:贪心。给定的刷子会把某区域内的颜色全部反转,因为刷两下和不刷是一模一样的,所以从左上角开始,一旦遇到了1,就刷一下。一个一个枚举,到最后如果图上还存在1,那就是不可能消除的。

代码如下:

/****************************************/
 #include <cstdio>
 #include <cstdlib>
 #include <cstring>
 #include <algorithm>
 #include <cmath>
 #include <stack>
 #include <queue>
 #include <vector>
 #include <map>
 #include <string>
 #include <iostream>
 using namespace std;
/****************************************/
bool mat[105][105];
//bool mat[105][105];

int main()
{
	int n, m, r, c;
	while(~scanf("%d%d%d%d", &n, &m, &r, &c), n||m||r||c) {
		char t;
		for(int i = 0; i < n; i++) {
			for(int j = 0; j < m; j++) {
				scanf(" %c", &t);
				mat[i][j] = t - '0';
			}
		}
		int op = 0;
		bool ok = true;
		for(int i = 0; i+r <= n; i++) {
			for(int j = 0; j+c <= m; j++) {
				if(mat[i][j] == 1) {
					op++;
					for(int k = i; k < i+r; k++) {
						for(int kk = j; kk < j+c; kk++) {
							mat[k][kk] = !mat[k][kk];
						}
					}
				}
			}
		}
		for(int i = 0; i < n; i++) {
			for(int j = 0; j < m; j++) {
				if(mat[i][j] == 1) {
					ok = false;
					break;
				}
			}
		}
		printf("%d\n", ok ? op : -1);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值