【DP】POJ-1157 LITTLE SHOP OF FLOWERS

69 篇文章 0 订阅

LITTLE SHOP OF FLOWERS
Time Limit: 1000MS Memory Limit: 10000K

Description
You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers.

Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0.

V A S E S

1 2 3 4 5

Bunches

1 (azaleas)
7 23 -5 -24 16

2 (begonias)
5 21 -4 10 23

3 (carnations)

-21
5 -4 -20 20

According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4.

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement.

Input

The first line contains two numbers: F, V.
The following F lines: Each of these lines contains V integers, so that Aij is given as the jth number on the (i+1)st line of the input file. 



1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F.
F <= V <= 100 where V is the number of vases.
-50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j. 

Output
The first line will contain the sum of aesthetic values for your arrangement.

Sample Input

3 5
7 23 -5 -24 16
5 21 -4 10 23
-21 5 -4 -20 20

Sample Output

53

Source
IOI 1999


题意: 有n多花要放在m个花盆里,其中第i+1种花必须放在第i朵花后面,特定的花放在特定的花盆里有不一样的权值,求出所能得到的最大权值。
思路: 简单DP,用dp[i][j]表示前i朵花已经放进前j个花盆里的权值和,则状态转移方程非常好想:
dp[i][j] = max{dp[i][j-1], dp[i-1][j-1]+w[i][j]}
决策: 要么花i放进花盆j里,要么花i放在前j-1个花盆里了。
注意: 状态转移方程最重要的就是状态必须是确定的,没有丝毫纰漏和瑕疵的。也就是说,当前dp值必须由已经确定、不会再改变的状态当中转移过来,否则错误。
P.S. 一开始我思考的决策是:要么放在当前花盆,要么放在后面的花盆,这是明显错误的,因为放在后面的花盆里这种状态是不确定的,所以dp值没有意义。
代码如下:

/*
 * ID: j.sure.1
 * PROG:
 * LANG: C++
 */
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <set>
#include <string>
#include <iostream>
#define PB push_back
#define LL long long
using namespace std;
const int INF = 0x3f3f3f3f;
const double eps = 1e-8;
/****************************************/
const int N = 105;
int n, m;
int w[N][N], dp[N][N];

int solve()
{
    for(int i = 1; i <= n; i++) {
        dp[i][i] = dp[i-1][i-1] + w[i][i];//初始化,花i最初至少在花盆i中,不能再靠前
        for(int j = i+1; j <= m; j++) {//dp[i][i]不可以被复写
            dp[i][j] = max(dp[i-1][j-1] + w[i][j], dp[i][j-1]);
        }//状态必须是已经确定的,所以决策是:要么放在这儿了,要么之前已经放过了
    }
    return dp[n][m];
}

int main()
{
#ifdef J_Sure
    freopen("000.in", "r", stdin);
    //freopen("999.out", "w", stdout);
#endif
    scanf("%d%d", &n, &m);
    for(int i = 1; i <= n; i++) {
        for(int j = 1; j <= m; j++) {
            scanf("%d", &w[i][j]);
        }
    }
    int ans = solve();
    printf("%d\n", ans);
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值