POJ1157 LITTLE SHOP OF FLOWERS(动态规划DP)

LITTLE SHOP OF FLOWERS

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 19011 Accepted: 8791

Description

You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers.

Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0.
 

V A S E S

1

2

3

4

5

Bunches

1 (azaleas)

723-5-2416

2 (begonias)

521-41023

3 (carnations)

-21

5-4-2020

According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4.

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement.

Input

  • The first line contains two numbers: F, V.
  • The following F lines: Each of these lines contains V integers, so that Aij is given as the jth number on the (i+1)st line of the input file.


  • 1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F.
  • F <= V <= 100 where V is the number of vases.
  • -50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.

Output

The first line will contain the sum of aesthetic values for your arrangement.

Sample Input

3 5
7 23 -5 -24 16
5 21 -4 10 23
-21 5 -4 -20 20

Sample Output

53

题目大意:

有n束花,m个花瓶,每束花插到每个花瓶都有对应的美观值,求所给样例美观值和最大为多少。


解题思路:

用dp[i][j]表示把i束花插进j个花瓶中,我们可以考虑一下,假设花瓶数目小于花的数目,那么dp[i][j] = 0 (i < j),另一种边界情况是dp[0][j]表示,0束花插进j个花瓶中,没有花就没有什么美观值可言了,所以其值也为0,接下来我们就可以来写状态转移方程了,假设花瓶数等于花的数目,那么题目又要求不能在同行同列,那么很容易写出状态方程dp[2][2] = dp[1][1] + val[2][2],如果不想等的情况呢?那么我们就要考虑花插不插入花瓶中了,dp[2][3]表示2朵花插入3个花瓶中,dp[1][2]表示1朵花插入2个花瓶中,现在考虑下如果把第二朵花插入到第三个瓶子中,那么我们可以根据已经求出的dp[1][2]写出状态方程dp[i][j] = dp[i-1][j-1] + val[i][j],如果不插入到第三个瓶子中,那么dp[i][j] = dp[i][i].

代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;

const int maxn = 200;

int dp[maxn][maxn];
int val[maxn][maxn];
int main()
{
    int m,n,i,j;
    //freopen("111","r",stdin);
    while(cin>>m>>n)
    {
        for(i=1;i<=m;i++)
        {
            for(j=1;j<=n;j++)
            {
                cin>>val[i][j];
            }
        }
        for(i=0;i<=m;i++)
        {
            dp[0][j] = 0;//没插花的时候美观值为0
        }
        for(i=1;i<=m;i++) //花的个数和瓶子一样时
        {
            dp[i][i] = dp[i-1][i-1] + val[i][i];
        }
        for(i=1;i<=m;i++)  //花
        {
            for(j=i+1;j<=n;j++) //瓶子,当j小于i的时候显然是没有意义的,因为瓶子数小于花,由于花和瓶子数一样的时候已经处理过,所以从i+1开始
            {
                dp[i][j] += max(dp[i][j-1],dp[i-1][j-1]+val[i][j]);
            }
        }
        cout<<dp[m][n]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值