华为笔试之字符串旋转

时间:2014.04.08

地点:基地二楼

说明:这些练习尽量按Google C++标准规范编写,环境 VS2013,语言:C++11

--------------------------------------------------------------------------------

一、题目

输入一串字符串(长度最大为100),可能包括小写字母、大写字母,数字、其他符号等等。要求将小写字母变成下一个字母(a—->b, b—->c),但是小写z变成小写A(这就是旋转的意思啦!),大写字母也变成大写字母的下一个字母(如A—>B,B—->C……..),但是大写Z变成大写A。大写字母变完还是大写字母,小写字母变完还是小写字母。数字和其他符号不变。

输入样例:abcABCz@123

输出样例:bcdBCDa@123

#include<iostream>
#include<string>
#include<cctype>
#include<cassert>
using namespace std;

string StringRotation(const string& str);
//Preconditon: The input string's lenth is not more than 100
//Postcondition: Return a rotation string with an transfer:a->b,b->c...
//               z->a and A->B,B->C...Z->A.Other characters are remain.
//Library facilities used:cassert,string

int main()
{
	string input_str = "", out_str = "";
	cout << "Please input a string whitch you want to process:"<<endl;
	cin >> input_str;
	out_str = StringRotation(input_str);
	cout << "The input string \"" << input_str << "\"" << " after rotation is: " 
		 <<endl<< out_str << endl;
	return EXIT_SUCCESS;
}
string StringRotation(const string& str)
{
	assert(str.length() <= 100);
	string result_str = "";
	for (auto ch : str)
	{
		if (isalpha(ch))
		{
			if (ch == 'z' || ch == 'Z')
				result_str += ch - 25;
			else
				result_str += ch + 1;
		}
		else
			result_str += ch;
	}
	return result_str;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值