时间:2014.04.08
地点:基地二楼
说明:这些练习尽量按Google C++标准规范编写,环境 VS2013,语言:C++11
--------------------------------------------------------------------------------
一、题目
输入一串字符串(长度最大为100),可能包括小写字母、大写字母,数字、其他符号等等。要求将小写字母变成下一个字母(a—->b, b—->c),但是小写z变成小写A(这就是旋转的意思啦!),大写字母也变成大写字母的下一个字母(如A—>B,B—->C……..),但是大写Z变成大写A。大写字母变完还是大写字母,小写字母变完还是小写字母。数字和其他符号不变。
输入样例:abcABCz@123
输出样例:bcdBCDa@123
#include<iostream>
#include<string>
#include<cctype>
#include<cassert>
using namespace std;
string StringRotation(const string& str);
//Preconditon: The input string's lenth is not more than 100
//Postcondition: Return a rotation string with an transfer:a->b,b->c...
// z->a and A->B,B->C...Z->A.Other characters are remain.
//Library facilities used:cassert,string
int main()
{
string input_str = "", out_str = "";
cout << "Please input a string whitch you want to process:"<<endl;
cin >> input_str;
out_str = StringRotation(input_str);
cout << "The input string \"" << input_str << "\"" << " after rotation is: "
<<endl<< out_str << endl;
return EXIT_SUCCESS;
}
string StringRotation(const string& str)
{
assert(str.length() <= 100);
string result_str = "";
for (auto ch : str)
{
if (isalpha(ch))
{
if (ch == 'z' || ch == 'Z')
result_str += ch - 25;
else
result_str += ch + 1;
}
else
result_str += ch;
}
return result_str;
}