hdu oj 1242 Rescue

Rescue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14222 Accepted Submission(s): 5164


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........

Sample Output
  
  
13

Author
CHEN, Xue

Source

Recommend
Eddy | We have carefully selected several similar problems for you: 1240 1016 1010 1072 1241

第一次使用STL的优先队列解决问题,这道题其实就是广搜,只不过把广搜的普通队列换成了priority_queue,单调队列吧。。。其实现在还不大懂 下面奉上AC代码:


#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;

const int maxn = 200;
int m,n,maze[maxn+10][maxn+10];
int dir[][2]={{1,0},{-1,0},{0,1},{0,-1}};

typedef struct point
{
    int x,y,t;
    bool operator < (const point &a) const
    {
        return t>a.t;
    }
} point;

point start;

int bfs()
{
    priority_queue<point>que;
    point cur,next;
    maze[start.x][start.y]='#';
    que.push(start);
    while(!que.empty())
    {
        cur=que.top();
        que.pop();
        for(int i=0;i<4;i++)
        {
            next.x=cur.x+dir[i][0];
            next.y=cur.y+dir[i][1];
            next.t=cur.t+1;
            if(next.x<1||next.x>=m+1||next.y<1||next.y>=n+1)
                continue;
            if(maze[next.x][next.y]=='#')
                continue;
            if(maze[next.x][next.y]=='r')
                return next.t;
            if(maze[next.x][next.y]=='.')
            {
                maze[next.x][next.y]='#';
                que.push(next);
            }
            else if(maze[next.x][next.y]=='x')
            {
                maze[next.x][next.y]='#';
                next.t++;
                que.push(next);
            }
        }
    }
    return -1;
}

int main()
{
    while(~scanf("%d%d",&m,&n))
    {
    memset(maze,0,sizeof(maze));
    for(int i=1;i<=m;i++)
        for(int j=1;j<=n;)
    {
        char c;
        scanf("%c",&c);
        if(c=='#'||c=='.'||c=='a'||c=='x'||c=='r')
        {
            maze[i][j++]=c;
            if(c=='a')
                start.x=i,start.y=j-1,start.t=0;
        }
    }
    int ans=bfs();
    printf(ans+1?"%d\n":"Poor ANGEL has to stay in the prison all his life.\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值