HDU-1242 Rescue

HDU-1242 Rescue

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel’s friends want to save Angel. Their task is: approach Angel. We assume that “approach Angel” is to get to the position where Angel stays. When there’s a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. “.” stands for road, “a” stands for Angel, and “r” stands for each of Angel’s friend.

Process to the end of the file.

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing “Poor ANGEL has to stay in the prison all his life.”

Sample Input
7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........
Sample Output
13


题目网址:http://acm.hdu.edu.cn/showproblem.php?pid=1242

分析

题意:大概题意就是天使被关起来了,然后天使的朋友要救天使,在一个M*M的矩阵中,天使被关在一个位置,天使的朋友要从自己的位置走到天使的位置,每走一步要用一个单位的时间,如果碰到守卫就要杀死他,杀死守卫也要要用一个单位的时间,最后输出所用的最少的时间,如果到达不了天使的位置,输出“Poor ANGEL has to stay in the prison all his life.”

思路:首先呢,这是一道广搜题,我用到了优先级队列,因为杀死守卫浪费1个单位时间,就代表了走到守卫的位置用了2个单位时间,所以要对每次进队的位置根据步数进行排序,然后从天使朋友的位置开始搜索周围的4个方向,先判断是否可走,如果可走,就让步数+1,碰到守卫步数+2并标记为已走,然后进队,如果不可走就直接跳过,4个方向都判断过后再从队首表示的位置开始搜索,依次搜索下去,直到走到天使的位置,如果队为空就表示走不到天使的位置。

代码
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
char dt[200][200];
int m,n,xl,xt,yl,yt;
int xy[4][2]={1,0,0,-1,0,1,-1,0},temp[200][200];
struct cmp
{
    int i,j,pre;
    friend bool operator < (cmp a,cmp b)
    {
        return a.pre>b.pre;
    }
};
priority_queue<cmp>it;
int DFS(int x,int y)
{
    memset(temp,0,sizeof(temp));
    cmp e,o;
    e.i=xl;
    e.j=yl;
    e.pre=0;
    it.push(e);
    temp[e.i][e.j]=1;
    while (!it.empty())
    {
        e=it.top();
        it.pop();
        if (dt[e.i][e.j]=='r')
        {
            return e.pre;
        }
        for (int t=0;t<4;t++)
        {
            o=e;
            o.i+=xy[t][0];
            o.j+=xy[t][1];
            if (dt[o.i][o.j]=='#'||o.i>=m||o.j>=n||o.i<0||o.j<0||temp[o.i][o.j]==1)
                continue;
            o.pre++;
            if (dt[o.i][o.j]=='x')
                o.pre++;
            temp[o.i][o.j]=1;
            it.push(o);
        }
    }
    return 0;
}
int main()
{
    while (scanf("%d %d",&m,&n)!=EOF)
    {
        temp[200][200]={0};
        for (int k=0;k<m;k++)
        {
            getchar();
            for (int l=0;l<n;l++)
            {
                scanf("%c",&dt[k][l]);
                if (dt[k][l]=='a')
                {
                    xl=k;
                    yl=l;
                }
            }
        }
        int num=DFS(xl,yl);
        if (num)
            printf("%d\n",num);
        else
            printf("Poor ANGEL has to stay in the prison all his life.\n");
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值