poj 3169 Layout

Layout
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6662 Accepted: 3220

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

Source


差分约束系统的典型,可以利用bellman-ford或者spfa解决,spfa效率更高,在判负环的时候开一个ord数组,判断位置是否超过边数:
判断负权回路的方案很多
1、记录每个结点进队次数,超过|V|次表示有负环;
2、记录这个结点在路径中处于的位置ord[i],每次更新的时候ord[i]=ord[x]+1,若超过|V|则表示有负环
看错顶点个数,内存超出限制,~~~~(>_<)~~~~ ,下边是AC代码:
/*
13074017	motefly	3169	Accepted	4644K	110MS	G++	1607B	2014-07-14 11:17:08
*/
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
const int MAX_V=1005;
const int INF=0x3f3f3f3f;
int N,ML,MD;
int cnt;
int G[MAX_V][MAX_V];
int d[MAX_V],ord[MAX_V],mark[MAX_V];
void init()
{
    memset(G,INF,sizeof(G));
    scanf("%d%d%d",&N,&ML,&MD);
    for(int i=1;i<=N;i++)
        G[i][i-1]=0;
    for(int i=0;i<ML;i++)
    {
        int f,t,c;
        scanf("%d%d%d",&f,&t,&c);
        G[f][t]=c;
        if(f+1!=t&&t+1!=f)
            cnt++;
    }
    for(int i=0;i<MD;i++)
    {
        int f,t,c;
        scanf("%d%d%d",&f,&t,&c);
        G[t][f]=-c;
        if(f+1!=t&&t+1!=f)
            cnt++;
    }
    cnt+=N-1;
}


int spfa(int v)
{
    for(int i=1;i<=N;i++)
        d[i]=INF;
    queue<int> q;
    q.push(v);
    ord[v]=1;
    mark[v]=1;
    d[v]=0;
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        mark[u]=0;
        for(int i=1;i<=N;i++)
        {
            if(G[u][i]!=INF)
            {
                if(d[u]+G[u][i]<d[i])
                {
                    d[i]=d[u]+G[u][i];
                    ord[i]=ord[u]+1;
                    if(!mark[i])
                    {
                        q.push(i);
                        mark[i]=1;
                    }
                    if(ord[i]>cnt)
                        return -1;
                }
            }
        }
    }
    if(d[N]==INF)
        return -2;
    return d[N];
}

int main()
{
    init();
    cout<<spfa(1)<<endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值