POJ - 3169 Layout (差分约束)(SPFA)

POJ - 3169 Layout (差分约束)(SPFA)(kuangbin)

 

 Problem

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

 



题意:

一共有n头牛,有ML个关系好的牛的信息,有MD个关系不好的牛的信息,
对应输入的第一行的三个元素:

1,接下来ML行,每行三个元素A,B,D,表示A牛和B牛相距不希望超过D。
2,接下来MD行,每行三个元素A,B,D表示A牛和B牛的相距至少要有D才行。
3,求1号牛和n号牛的最大距离,如果距离无限大输出-2,如果无解输出-1。

思路:

条件1:A->B的最大距离不超过D,即dist[B]-dist[A]<=D;   

条件1:A->B的最大距离不小于D,即dist[B]-dist[A]>=D,两边同乘-1      dist[A]-dist[B]<= -D

这样,我们得到两个不等式   dist[B]-dist[A]<=D, A----->B  w= D;

                                              dist[A]-dist[B]<= -D  B----->A  w= -D;

这样建边求最短路即可

这就是差分约束系统,我们就可以根据这俩个不等式把问题转换成求最短路问题。

差分约束系统 相关概念 :https://www.cnblogs.com/genius777/p/9163103.html

对应输出:

①如果dist【n】==inf,输出-2;

②否则输出dist【n】;

③如果在跑SPFA过程中发现了负环,说明问题无解,那么输出-1.

 

#include<iostream>
#include<queue>
#include<string.h>
using namespace std;


#define INF 0x3f3f3f3f
#define ll long long
int N,ML,MD;
int dist[1010],vis[1010],out[1010];//out记录每个点的入队次数
int total,head[1010];
bool flag;//标记图是否有负环
struct Edge
{
    int to,w,next;
    Edge() {}
    Edge(int to,int w,int next):to(to),w(w),next(next) {}
} edge[20010];

void addEdge(int u,int v,int w)//建图,给边编号
{
    edge[total].to=v;
    edge[total].w=w;
    edge[total].next=head[u];
    head[u]=total++;
}
void SPFA()
{
    queue<int> q;
    fill(dist,dist+1010,INF);
    memset(vis,0,sizeof(vis));
    memset(out,0,sizeof(out));
    dist[1]=0,  out[1]++, q.push(1);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        vis[u]=0;
        for(int i=head[u]; i!=-1; i=edge[i].next)
        {
            int v=edge[i].to;
            int w=edge[i].w;
            if(dist[v]>dist[u]+w)
            {
                dist[v]=dist[u]+w;
                if(vis[v]==0)
                {
                    vis[v]=1, q.push(v);
                    if(++out[v]>N)
                    {
                        flag=true;
                        cout<<-1<<endl;
                        return;
                    }
                }
            }
        }
    }
}
int  main()
{
    cin>>N>>ML>>MD;
    total=0;
    flag=false;
    memset(head,-1,sizeof(head));
    for(int i=1; i<=ML; i++)// u----->v  w= D;
    {
        int u,v,w;
        cin>>u>>v>>w;
        addEdge(u,v,w);
    }
    for(int i=1; i<=MD; i++)//v----->u  w= -D
    {
        int u,v,w;
        cin>>u>>v>>w;
        addEdge(v,u,-w);
    }
    SPFA();
    if(!flag)
    {
        if(dist[N]==INF)
            cout<<-2<<endl;
        else
            cout<<dist[N]<<endl;
    }

    return 0;
}

 

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值