BOBSLEDDING(一道有趣的贪心题 nyoj309)

2 篇文章 0 订阅

BOBSLEDDING

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述

Dr.Kong has entered a bobsled competition because he hopes his hefty weight will give his an advantage over the L meter course (2 <= L<= 1000). Dr.Kong will push off the starting line at 1 meter per second, but his speed can change while he rides along the course. Near the middle of every meter Bessie travels, he can change his speed either by using gravity to accelerate by one meter per second or by braking to stay at the same speed or decrease his speed by one meter per second.

Naturally, Dr.Kong must negotiate N (1 <= N <= 500) turns on the way down the hill. Turn i is located T_i  meters from the course start (1 <= T_i <= L-1), and  he must be enter the corner meter at  a peed of at most S_i  meters per second (1 <= S_i <= 1000).  Dr.Kong can cross the finish line at any speed he likes.

Help Dr.Kong learn the fastest speed he can attain without exceeding the speed limits on the turns.

Consider this course with the meter markers as integers and the  turn speed limits in brackets (e.g., '[3]'):

       0    1   2   3   4   5   6   7[3]   8   9  10  11[1]  12   13[8]    14                    

(Start) |------------------------------------------------------------------------|  (Finish)   

                    

Below is a chart of  Dr.Kong 's speeds at the beginning of each meter length of the course:

Max:                               [3]             [1]      [8]

Mtrs:   0   1   2   3   4   5   6   7   8   9  10  11  12   13   14 

Spd:    1   2   3   4   5   5   4   3   4   3   2   1   2   3    4

His maximum speed was 5 near the beginning of meter 4.

输入
There are multi test cases,your program should be terminated by EOF
Line 1: Two space-separated integers: L and N
Lines 2..N+1: Line i+1 describes turn i with two space-separated integers: T_i and S_i
输出
Line 1: A single integer, representing the maximum speed which Dr.Kong can attain between the start and the finish line, inclusive.
样例输入
14 3                                            
7 3
11 1
13 8
样例输出
5
来源
第四届河南省程序设计大赛
上传者

张云聪

题意: Mr。kong 要去滑雪 雪道长L 有n个拐点 速度不能超过某个值

一开始 你速度每米增加1 如果保持不变 下一秒每秒减去1

问你在长度为l 雪道上出现的速度 最高为多少

思路: 每次从拐点开始往回减小 入门前一个比当前的值+1要大 的时候

#include<bits/stdc++.h>
using namespace std;
struct point
{
    int x,y;
}p[505];
int l,n;
int sp[1005];
int a,b;

int cmp(point a,point b)
{
    return a.x<b.x;
}

int main()
{
    int l,n;
    while(~scanf("%d%d",&l,&n))
    {
        for(int i=0;i<n;i++)
            scanf("%d%d",&p[i].x,&p[i].y);

        sort(p,p+n,cmp);

        sp[0] = 1;
        for(int i=1;i<=l;i++)//初始
            sp[i]=sp[i-1] + 1;
        for(int i=0;i<n;i++)
        {
            a=p[i].x;
            b=p[i].y;
            if(sp[a]>b) sp[a] = b;// 拐点限制的值
            for(int j=a-1;sp[j]>sp[j+1]+1&&j>=0;j--)//开始递减
            {
                sp[j] = sp[j+1] + 1;
            }
        }
        int Mx=sp[0];
        for(int i=1;i<=l;i++)
        {
            if(sp[i]>sp[i-1]+1) sp[i] = sp[i-1]+1;
            Mx=max(Mx,sp[i]);
        }
        printf("%d\n",Mx);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值