Usaco 2.4Overfencing(BFS)

Overfencing
PS:真想吐槽下,各种胡搞,幸亏在读入图的时候稍微剪了下,还好过了,之前无数TLE!!!!!!!!这题害我搞了好几天,好辛苦,求赞和评论~~~~~~

————————————————————————————————————————————————————————————
Kolstad and Schrijvers

Farmer John went crazy and created a huge maze of fences out in a field. Happily, he left out two fence segments on the edges, and thus created two "exits" for the maze. Even more happily, the maze he created by this overfencing experience is a `perfect' maze: you can find a way out of the maze from any point inside it.

Given W (1 <= W <= 38), the width of the maze; H (1 <= H <= 100), the height of the maze; 2*H+1 lines with width 2*W+1 characters that represent the maze in a format like that shown later - then calculate the number of steps required to exit the maze from the `worst' point in the maze (the point that is `farther' from either exit even when walking optimally to the closest exit). Of course, cows walk only parallel or perpendicular to the x-y axes; they do not walk on a diagonal. Each move to a new square counts as a single unit of distance (including the move "out" of the maze.

Here's what one particular W=5, H=3 maze looks like: +-+-+-+-+-+|         |+-+ +-+ + +|     | | |+ +-+-+ + +| |     |  +-+ +-+-+-+

Fenceposts appear only in odd numbered rows and and odd numbered columns (as in the example). The format should be obvious and self explanatory. Each maze has exactly two blank walls on the outside for exiting.

PROGRAM NAME: maze1

INPUT FORMAT

Line 1:W and H, space separated
Lines 2 through 2*H+2:2*W+1 characters that represent the maze

SAMPLE INPUT (file maze1.in)

5 3+-+-+-+-+-+|         |+-+ +-+ + +|     | | |+ +-+-+ + +| |     |  +-+ +-+-+-+

OUTPUT FORMAT

A single integer on a single output line. The integer specifies the minimal number of steps that guarantee a cow can exit the maze from any possible point inside the maze.

SAMPLE OUTPUT (file maze1.out)

9
————————————————————————————————————————————————————————————-
PS:真想吐槽下,各种胡搞,幸亏在读入图的时候稍微剪了下,还好过了,之前无数TLE!!!!!!!!这题害我搞了好几天,好辛苦,求赞和评论~~~~~~

 

 

/*
ID:shi13891
LANG:C++
PROG:maze1
*/
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
 

using namespace std;
 

char map[210][210];

int dx[] = {-1,0,1,0};
int dy[] = {0,1,0,-1};

struct node
{
 int x;
 int y;
 int time;
};

int w,h,W,H;
bool mark[210][210];
 

int BFS(int x,int y)
{
  if(x==0||y==0||x==H-1||y==W-1)
        return 0;

  queue<node>q;
  struct node first,Now,tmp;
  first.x=x;
  first.y=y;
  first.time=0;
  q.push(first);
  memset(mark,0,sizeof(mark));
  while(!q.empty())
  {
    Now=q.front();
     q.pop();
    if(mark[Now.x][Now.y] == 1)
            continue;
    mark[Now.x][Now.y] = 1;
    for(int i=0;i<4;i++)
    {
      int xx=Now.x+dx[i];
      int yy=Now.y+dy[i];
      if((xx>=0&&yy>=0&&xx<H&&yy<W)&&(map[xx][yy]==' ')&&(xx==0||yy==0||xx==H-1||yy==W-1))
      {
       return Now.time+1;
      }
      if(map[xx][yy]==' ')
      {
        tmp.x = xx + dx[i];
        tmp.y = yy + dy[i];
        tmp.time=Now.time+2;
        q.push(tmp);
     }
   }
  }
  return 0;
}

int main()
{
  freopen("maze1.in", "r", stdin);
  freopen("maze1.out", "w", stdout);
 

  scanf("%d%d%*c", &w, &h);//这儿读入整数的技巧很重要,不加*c会WA,第二组数据直接跪。
 

  w = 2*w+1;W = w;
  h = 2*h+1;H = h;
 

  for(int i = 0; i < h; i++)
  {
   gets(map[i]);
  }

  int ans=0;
  for(int i=0;i<h;i++)
  {
   for(int j=0;j<w;j++)
   {
    if(map[i][j]==' '&&i%2==1&&j%2==1)
    {
      int tmp=BFS(i,j);
     ans=max(ans,tmp);
    }
    else
                continue;//不处理其他情况。算是剪了一部分吧。这才水果,本来跪在第六组数据了,(TLE),剪了之后即使是第十组数据时间也不错,都是4、500ms。。。好~~
  }
 }
 cout<<(ans-1)/2+1<<endl;
 fclose(stdin);
 fclose(stdout);
 return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值