What Are You Talking About
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 102400/204800 K (Java/Others)Total Submission(s): 10686 Accepted Submission(s): 3411
Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
Output
In this problem, you have to output the translation of the history book.
Sample Input
START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END
Sample Output
hello, i'm from mars.
i like earth!
分析:其实本题完全可以用map写,不过学习trie就用trie写了下,思路很简单,不过在TrieNode结构体内增加了一个辅助数组target罢了。。
i like earth!
分析:其实本题完全可以用map写,不过学习trie就用trie写了下,思路很简单,不过在TrieNode结构体内增加了一个辅助数组target罢了。。
/*************************************************************************
* author:crazy_石头
* algorithm:Trie
* date:2013/09/29
**************************************************************************/
#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <ctype.h>
using namespace std;
struct TrieNode
{
struct TrieNode *next[26];
char target[15];
bool ok;
};
char ans[15];
int flag;
TrieNode *root=new TrieNode;
void build(char *s,char *str)
{
TrieNode *p=root,*q;
int len=strlen(s);
for(int i=0;i<len;i++)
{
if(p->next[s[i]-'a']!=NULL)
p=p->next[s[i]-'a'];
else
{
q=new TrieNode;
for(int j=0;j<26;j++)
{
q->next[j]=NULL;
q->ok=false;
}
p->next[s[i]-'a']=q;
p=q;
}
}
p->ok=true;
strcpy(p->target,str);
}
void Search(char *s)
{
TrieNode *p=root;
int len=strlen(s);
for(int i=0;i<len;i++)
{
if(p->next[s[i]-'a']!=NULL)
p=p->next[s[i]-'a'];
else
{
flag=1;
return;
}
}
if(p->ok==false)
{
flag=1;
return;
}
strcpy(ans,p->target);
}
int main()
{
char s1[15],s2[15],temp[15];
char str[3001];
int i,j,len,cur_len;
for(i=0;i<26;i++)
{
root->next[i]=NULL;
root->ok=false;
}
scanf("%s",s1);
while(scanf("%s",s1),strcmp(s1,"END")!=0)
{
scanf("%s",s2);
build(s2,s1);
}
scanf("%s%*c",str);
while(gets(str)&&strcmp(str,"END")!=0)
{
len=strlen(str);
cur_len=0;
for(i=0;i<len;i++)
{
if(islower(str[i]))
temp[cur_len++]=str[i];
else
{
if(cur_len)
{
temp[cur_len]=0;
flag=0;
Search(temp);
if(flag) printf("%s",temp);
else printf("%s",ans);
}
if(str[i]) printf("%c",str[i]);
cur_len=0;
}
}
printf("\n");
}
return 0;
}