2013 ACM/ICPC Asia Regional Online —— Warmup HDU4707

Pet

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 586    Accepted Submission(s): 295


Problem Description
One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for three days. Nothing but cockroaches was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere nearer than distance D. Your task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is always one distance unit.

Input
The input contains multiple test cases. Thefirst line is a positive integer T (0<T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0<N<=100000) and D(0<D<N), separated by a single space. N is the number of locations in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0<=x,y<N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room is always at location 0.

Output
For each test case, outputin a single line the number of possible locations in the school the hamster may be found.

Sample Input
1
10 2
0 1
0 2
0 3
1 4
1 5
2 6
3 7
4 8
6 9

Sample Output

2

 

/**************************************************************
* problem:HDU 4707 --Pet
* source :2013 ACM/ICPC Asia Regional Online —— Warmup
* algorithm:直接DFS距离即可,找出大于给定距离的结点个数;
* author: crazy_石头
* date: 2013/09/10
* 备注;水题
* PS1:向bin神,neko13,雷神,wuyiqi神犇学习~
* PS2:秋天微冷,一发水题来热热身~~
****************************************************************/
#include <iostream>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <algorithm>

using namespace std;

const int maxn=100000+5;

struct Edge
{
    int to;
    int next;
}edge[maxn<<2];

int cnt;
int head[maxn];
int dis[maxn];//记录该节点到根的距离;
int res;//记录答案;
int num,n;

inline void addedge(int u,int v)
{
     edge[cnt].to=v;
     edge[cnt].next=head[u];
     head[u]=cnt++;
}

inline void DFS(int u,int father)
{
     if(dis[u]>num)
         res++;

     for(int i=head[u];~i;i=edge[i].next)
     {
         int v=edge[i].to;
         if(v!=father)
         {
             dis[v]=dis[u]+1;
             DFS(v,u);
         }
     }
}

int main()
{
     int test;
     scanf("%d",&test);
     while(test--)
     {
         cnt=0;
         res=0;//答案初值设为0;
         memset(head,-1,sizeof(head));

         scanf("%d%d",&n,&num);
         int t=n-1;
         while(t--)
         {
             int u,v;
             scanf("%d%d",&u,&v);

             addedge(u,v);
             addedge(v,u);
         }
         dis[0]=0;
         DFS(0,-1);
         printf("%d\n",res);
     }
     return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值