POJ3070矩阵快速幂求Fib

欲哭无泪。。。。。比赛的时候都敲不出来。。

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7770 Accepted: 5518

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

 
贴代码:
#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
 

using namespace std;
 

struct Matrix
{
    int a[2][2];
};

int n;
 

Matrix multiply(Matrix A,Matrix B)
{
    Matrix C;
    memset(C.a,0,sizeof(C.a));
    for(int i=0;i<2;i++)
    {
        for(int j=0;j<2;j++)
        {
            for(int k=0;k<2;k++)
            {
                C.a[i][j]+=A.a[i][k]*B.a[k][j];
                C.a[i][j]%=10000;
            }
        }
    }
    return C;
}
 

Matrix quick_pow(Matrix A,int n)
{
    Matrix ans;
    memset(ans.a,0,sizeof(ans.a));
    for(int i=0;i<2;i++)
    ans.a[i][i]=1;

    while(n)
    {
        if(n&1)
        {
            ans=multiply(ans,A);
        }
        A=multiply(A,A);
        n>>=1;
    }
    return ans;
}
 

int main()
{
    while(cin>>n&&n!=-1)
    {
        if(n==0)
        {
            cout<<0<<endl;
            continue;
        }
 

        Matrix res;
 

        res.a[0][0]=0;
        res.a[0][1]=1;
        res.a[1][0]=1;
        res.a[1][1]=1;
 

        res=quick_pow(res,n);
        cout<<res.a[0][1]%10000<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值