POJ 2406 kmp简单应用

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 29067 Accepted: 12143

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

已知一个字符串由多个子串重复若干次得到,求最大的重复次数,

思路:可以用kmp,也可以用后缀数组,后缀数组以后实现,kmp根据next数组可以得到循环节,进而可以得到重复次数。

代码:

/* ***********************************************
Author :xianxingwuguan
Created Time :2014-1-29 18:06:17
File Name :4.cpp
************************************************ */

#pragma comment(linker, "/STACK:102400000,102400000")
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>
using namespace std;
const int maxn=1002000;
char str[maxn];
int next[maxn];
int get_next(char *str)
{
      int j=0,k=-1;
      int len=strlen(str);
      next[0]=-1;
      while(j<len)
      {
	     if(k==-1||str[j]==str[k])
		    next[++j]=++k;
	     else k=next[k];
      }
      j=len-k;
      if(len%j==0)
	     return len/j;
      return 1;
}
int main()
{
      //freopen("data.in","r",stdin);
      //freopen("data.out","w",stdout);
      while(~scanf("%s",str)&&str[0]!='.')printf("%d\n",get_next(str));
      return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值