poj2406——经典循环节题

题目链接:

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

 

 

给定若干个长度 ≤ 1000000 的字符串,询问每个字符串最多是由多少个相同的子字符串重复连接而成的。如:ababab 则最多有 3 个 ab 连接而成。

输入格式

输入若干行,每行有一个字符串,字符串仅含英语字母。
输入数据以"."结束。

输出格式

对于每组输入数据输出一行,找出每个字符串最多是由多少个相同的子字符串重复连接而成的。

经典循环节题型,判断是否有循环节,并且求循环次数。

#include <iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int maxn=1e6+5;
int nxt[maxn];
string str;
void getnext(){
	nxt[0]=-1;
	int len=str.size();
	int j=0,k=-1;
	while(j<len){
		if(k==-1||str[j]==str[k]){
			j++;
			k++;
			nxt[j]=k;
		}
		else k=nxt[k];
	}
}
int main(int argc, char** argv) {
	ios_base::sync_with_stdio(0),cin.tie(0),cout.tie(0);
	while(cin>>str&&str[0]!='.'){
		int len=str.size();
		getnext();
		int t=len-nxt[len];
		if(len%t!=0) printf("1\n");
		else	printf("%d\n",len/t);
	}
	return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值