POJ 2084 卡特兰数+高精度模板

Game of Connections
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 7136 Accepted: 3625

Description

This is a small but ancient game. You are supposed to write down the numbers 1, 2, 3, . . . , 2n - 1, 2n consecutively in clockwise order on the ground to form a circle, and then, to draw some straight line segments to connect them into number pairs. Every number must be connected to exactly one another.
And, no two segments are allowed to intersect.
It's still a simple game, isn't it? But after you've written down the 2n numbers, can you tell me in how many different ways can you connect the numbers into pairs? Life is harder, right?

Input

Each line of the input file will be a single positive number n, except the last line, which is a number -1.
You may assume that 1 <= n <= 100.

Output

For each n, print in a single line the number of ways to connect the 2n numbers into pairs.

Sample Input

2
3
-1

Sample Output

2
5

Source


我是巩固一下卡特兰数,顺便存一下高精度模板的。

代码:

/* ***********************************************
Author :rabbit
Created Time :2014/3/27 13:57:20
File Name :7.cpp
************************************************ */
#pragma comment(linker, "/STACK:102400000,102400000")
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <sstream>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <time.h>
#include <math.h>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
#define INF 0x3f3f3f3f
#define eps 1e-8
#define pi acos(-1.0)
typedef long long ll;
const int maxn=9999;
const int maxsize=2020;
const int dlen=4;
class BigNum{
	private:
		int a[1000],len;
	public:
		BigNum(){
			len=1;memset(a,0,sizeof(a));
		}
		BigNum(const int b){
			int c,d=b;
			len=0;
			memset(a,0,sizeof(a));
			while(d>maxn){
				c=d-(d/(maxn+1))*(maxn+1);
				d=d/(maxn+1);
				a[len++]=c;
			}
			a[len++]=d;
		}
		BigNum(const char *s){
			int t,k,index,L,i;
			memset(a,0,sizeof(a));
			L=strlen(s);
			len=L/dlen;
			if(L%dlen)len++;
			index=0;
			for(int i=L-1;i>=0;i-=dlen){
				t=0;
				k=i-dlen+1;
				if(k<0)k=0;
				for(int j=k;j<=i;j++)
					t=t*10+s[j]-'0';
				a[index++]=t;
			}
		}
		BigNum(const BigNum &T):len(T.len){
			int i;
			memset(a,0,sizeof(a));
			for(int i=0;i<len;i++)
				a[i]=T.a[i];
		}
		BigNum operator = (const BigNum &n){
			int i;
			len=n.len;
			memset(a,0,sizeof(a));
			for(int i=0;i<len;i++)
				a[i]=n.a[i];
			return *this;
		}
		BigNum operator + (const BigNum &T) const{
			BigNum t(*this);
			int i,big;
			big=T.len>len?T.len:len;
			for(int i=0;i<big;i++){
				t.a[i]+=T.a[i];
				if(t.a[i]>maxn){
					t.a[i+1]++;
					t.a[i]-=maxn+1;
				}
			}
			if(t.a[big])t.len=big+1;
			else t.len=big;
			return t;
		}
		BigNum operator - (const BigNum &T) const{
			int i,j,big;
			bool flag;
			BigNum t1,t2;
			if(*this>T){
				t1=*this;
				t2=T;
				flag=0;
			}
			else{
				t1=T;
				t2=*this;
				flag=1;
			}
			big=t1.len;
			for(i=0;i<big;i++){
				if(t1.a[i]<t2.a[i]){
					j=i+1;
					while(t1.a[j]==0)j++;
					t1.a[j--]--;
					while(j>i)t1.a[j--]+=maxn;
					t1.a[i]+=maxn+1-t1.a[i];
				}
				else t1.a[i]-=t2.a[i];
			}
			t1.len=big;
			while(t1.a[len-1]==0&&t1.len>1){
				t1.len--;
				big--;
			}
			if(flag)t1.a[big-1]=0-t1.a[big-1];
			return t1;
		}
		BigNum operator * (const BigNum &T) const{
			BigNum ret;
			int i,j,up;
			int temp,temp1;
			for( i=0;i<len;i++){
				up=0;
				for( j=0;j<T.len;j++){
					temp=a[i]*T.a[j]+ret.a[i+j]+up;
					if(temp>maxn){
						temp1=temp-temp/(maxn+1)*(maxn+1);
						up=temp/(maxn+1);
						ret.a[i+j]=temp1;
					}
					else{
						up=0;
						ret.a[i+j]=temp;
					}
				}
				if(up)ret.a[i+j]=up;
			}
			ret.len=i+j;
			while(ret.a[ret.len-1]==0&&ret.len>1)ret.len--;
			return ret;
		}
		BigNum operator / (const int &b) const{
			BigNum ret;
			int i,down=0;
			for(int i=len-1;i>=0;i--){
				ret.a[i]=(a[i]+down*(maxn+1))/b;
				down=a[i]+down*(maxn+1)-ret.a[i]*b;
			}
			ret.len=len;
			while(ret.a[ret.len-1]==0&&ret.len>1)ret.len--;
			return ret;
		}
		BigNum operator % (const int &b) const{
			int i,d=0;
			for(int i=len-1;i>=0;i--)
				d=((d*(maxn+1))%b+a[i])%b;
			return d;
		}
		BigNum operator ^ (const int &n) const{
			BigNum t,ret(1);
			int i;
			if(n<0)exit(-1);
			if(n==0)return 1;
			if(n==1)return *this;
			int m=n;
			while(m>1){
				t=*this;
				for( i=1;(i<<1)<=m;i<<=1)t=t*t;
				m-=i;
				ret=ret*t;
				if(m==1)ret=ret*(*this);
			}
			return ret;
		}
		bool operator > (const BigNum &T) const{
			int ln;
			if(len>T.len)return true;
			else if(len==T.len){
				ln=len-1;
				while(a[ln]==T.a[ln]&&ln>=0)ln--;
				if(ln>=0&&a[ln]>T.a[ln])return true;
				else return false;
			}
			else return false;
		}
		bool operator > (const int &t) const{
			BigNum b(t);
			return *this>b;
		}
		void print(){
			int i;
			printf("%d",a[len-1]);
			for(int i=len-2;i>=0;i--)printf("%04d",a[i]);
			puts("");
		}
};
int main()
{
     //freopen("data.in","r",stdin);
     //freopen("data.out","w",stdout);
     BigNum f[110];
	 f[0]=BigNum(1);
	 //f[0].print();
	 for(int i=1;i<=100;i++)
		 f[i]=f[i-1]*BigNum(4*i-2)/(i+1);
	 int n;
	 while(cin>>n&&n>0)f[n].print();
     return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
题目描述 给定两个长度均为 $n$ 的数组 $A,B$,其中 $A$ 数组中的元素两两不同,$B$ 数组中元素也两两不同。 定义 $A$ 数组的第 $i$ 个元素为 $a_i$,$B$ 数组的第 $i$ 个元素为 $b_i$。定义一个四元组 $(i,j,k,l)$ 符合条件当且仅当 $1 \leq i < j \leq n$,$1 \leq k < l \leq n$,$$ a_i+b_j=k+l $$ 问有多少个符合条件的四元组。 输入 输入的第一行为一个整数 $n$,表示 $A$ 和 $B$ 数组的长度。 接下来 $n$ 行,第 $i$ 行包含两个整数 $A_i$ 和 $B_i$。 输出 输出一行,一个整数,表示符合条件的四元组个数。 输入样例 3 1 1 2 2 3 3 输出样例 6 提示 $1 \leq n \leq 1500$,$1 \leq A_i,B_i \leq 10^9$ 这一题要求解符合条件的四元组。其中有一个直观的想法就是将四元组分类讨论,如下所示: $$a_i + b_j = k + l$$ 分类讨论,当 $i < k, j < l$ 时就是一种方案,当 $i > k, j > l$ 时是另一种情况。 因此,对于每一种 $a_i + b_j$ 的和,记录下它的出现次数,同时记录下这个和所对应的 $i, j$ 的值。在计算的过程中,如果遇到相同的和的时候,再次遇到时是可以直接忽略的,因为等式是对称的。 统计符合条件的四元组当然要对和进行枚举,但是值得注意的是,在构造符合条件的 $k, l$ 的时候,数组 $C$ 和 $D$ 的记录顺序是无关紧要的,因为等式 $a_i + b_j = k + l$ 已经将每个数字都制约了,它们可以出现任意的顺序。因此,在统计 $C$ 和 $D$ 对于计算答案来说是无区别的。 这一题值得别注意的是,当数组中有数据的时候,要注意考虑到数据越界可能导致结果错误。在本题中,由于 $a_i, b_j$ 的上限是 $10^9$,因此 $a_i + b_j$ 的上限最大可能会达到 $2 \times 10^9$,因此在计算时一定要使用 long long 类型,否则很容易产生错误。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值