hdu 1005——Number Sequence

水题。但并不容易我是看题解才知道周期的,我也知道有周期可求不出来!!!!!

大神物语:凡是给出运算公式的数学题,只要没有优化的话,超时超内存是避免不了的!

如果直接根据式子写出for循环,则会爆栈。所以自己要根据给的式子找周期,该题明显是找规律的题,找它的运算周期由关系式可知每一项只与它的前两项有关,

所以当连续的两项在前面出现过,则循环节出现。
对于公式f[n]=a*f[n-1]+b*f[n-2];后者只有7*7=49种可能。

为什么这么说,因为对于f[n-1]或f[n-2]的取值只有0,1,2,3,4,5,6,7种可能
又因为a,b固定,所以前后相乘产生49种可能。

一组测试数据中最坏的情况是49种情况都遇到,那么会在第50次运算中产生循环节

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 115443    Accepted Submission(s): 28057


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
#include<stdio.h>
int main()
{
    int a,b,n,m,t;
    int f[1010]={0,1,1};
    
    while(scanf("%d%d%d",&a,&b,&n),a,b,n)
    {
        for(int i=3;i<49;i++)
        f[i]=(a*f[i-1]+b*f[i-2])%7;
        printf("%d\n",f[n%49]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值