hdu1005 Number Sequence

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
Sample Output
2
5
法一
#include <iostream>
using namespace std;

int arr[10000]; 
 
int main()
{
	int A,B,n;
	arr[1] = arr[2] = 1;
	while(cin>>A>>B>>n, A || B || n)
	{
		int i;
		for(i=3; i<10000 ;i++)
		{
			arr[i] = (A*arr[i-1] + B*arr[i-2]) % 7;
			
			//如果有两个连着 =1,则后面的全部和前面相同,即出现了周期
			//这时就没必要再进行下去了,跳出循环, i-2为周期 
			if(arr[i] == 1 && arr[i-1] == 1)			
				break;
		}
		n = n % (i-2);
		
		// 把n对周期求模,当n = i-2时, n=0,此时本来应该取arr[i-2]的,所以把arr[0]=arr[i-2] 
		//也可以这样:
		//if(n==0)	 n=i-2; 	           
		arr[0] = arr[i-2];	
		cout << arr[n] << endl;
	}
	return 0;
}

法二

 

#include<stdio.h>
#include<string.h>
int main()
{
    int a,b,n,i;
    while(1)
    {
        scanf("%d%d%d",&a,&b,&n);
		if(a==0&&b==0&&n==0)
			break;
		int f[1009];
		f[1]=1;
		f[2]=1;
		for(i=3;i<=1008;i++)
		{
			
			f[i]=(a*f[i-1]+b*f[i-2])%7;
			
			
		}
		printf("%d\n",f[(n-1)%1008+1]);
	}
	return 0;
}

数学的运用。嘻嘻

  • 7
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值