CocoaPods安装过程的注意事项

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/u012437355/article/details/52504078

写在前面

关于CocoaPods的安装和基本使用,已有大神总结的很好了,这里只是以安装步骤为主线,写出修改后的命令(之前的命令现在许多更新,自己失败了多次),建议先阅读下面推荐的第一篇博客了解大体思路之后再返回阅读本篇。
推荐几篇博客,方便大家学习:
CocoaPods详解之—-使用篇
CocoaPods详解之—-进阶篇
CocoaPods详解之—-制作篇

详细内容

说明:1.这里的Mac安装的系统版本为10.11.3 (15D21)

  • Mac已经支持运行Ruby,这里我们需要更新RVM和Ruby的版本

    sudo gem update --system // 更新RVM版本
    rvm install ruby-2.3.0 // 更新ruby版本
  • 下载完成后,使用新版本

    rvm --default use ruby-2.3.0 // 切换ruby的版本
    rvm list // 查看所有安装的ruby版本
  • 准备安装CocoaPods
    由于需要访问墙外的资源,这里把目的地切换为国内的。
  • 切换Ruby的默认源

    gem sources --remove https://rubygems.org/
    gem sources -a https://ruby.taobao.org/ 
  • 安装CocoaPods(可能会比较耗时)

    sudo gem install cocoapods // 安装和升级命令
  • 启动CocoaPods (可能会比较耗时)

    pod setup
  • 编写Podfile的注意问题,下面给出一个示例

    platform:ios, '7.0'
    //下面是新的写法
    target "CocoapodsDemo" do
    pod 'AFNetworking', '~> 3.1.0'
    end
  • 导入第三方库

    pod install

若大家发现错误,欢迎指正。共同交流,共同进步!谢谢阅读!

阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页