HODJ Big Number(java 阶乘)

18 篇文章 0 订阅
17 篇文章 0 订阅

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24822    Accepted Submission(s): 11266


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
  
  
2 10 20
 

Sample Output
  
  
7 19
超时代码:以为用大数可以解决,结果发现求千万数量级的阶乘内存也无法受得了
import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    
    
    public static void main(String[] args) {
        
        Scanner in = new Scanner(System.in);
        int n = in.nextInt();
        while(n-->0){
            String str = in.next();
            BigInteger number = new BigInteger(str);
            BigInteger sum = BigInteger.ONE;
            while(number.intValue()>0){
                
                sum = sum.multiply(number);
                number = number.subtract(BigInteger.ONE);
                
            }
            
            System.out.println(sum.toString().length());
            
        }
        

    }

}

AC代码1:利用数学中对数公式可以求解出,lg(N!)=lg(1)+lg(2)+…+lg(N)
import java.util.Scanner;

public class Main {
    
    public static void main(String[] args) {
        
        Scanner in = new Scanner(System.in);
        int n = in.nextInt();
        while(n-->0){
            double d = in.nextDouble();
            double sum = 0;
            for(int i=1; i<=d; i++){    
                sum += Math.log10(i);
            }
    
            System.out.println((int)sum+1);
            
        }
        

    }

}

AC代码2:采用斯特林公式计算能够在时间上快速解决
import java.util.Scanner;

public class Main {
    

    public static void main(String[] args) {
        
        Scanner in = new Scanner(System.in);
        int n = in.nextInt();
        while(n-->0){
            int number = in.nextInt();
            double sum1 = Math.log10(Math.sqrt(2*Math.PI*number));
            double sum2 = number*Math.log10(number/Math.E);
            System.out.println((int)(sum1+sum2+1));
            
        }
        

    }

}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值