Problem Description(1016)
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6 8
Sample Output
Case 1:
1 4 3 2 5 6 1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
#include<stdio.h>
int n,a[21];
int check(int m) { int i;
for(i=m-1;i>=1;i--) { if(a[i]==a[m])
return 0;
} return 1;
}
int isPrime(int m) { int i;
for(i=2;i<m;i++) { if(m%i==0)
return 0;
} return 1;
}
void ACM(int m) {
int i;
if(m>n) { if(isPrime(a[n]+a[1])&&check(n)) {
for(i=1;i<n;i++)
printf("%d ",a[i]); printf("%d\n",a[n]);
}
} else{
for(i=2;i<=n;i++) { a[m]=i;
if(isPrime(a[m]+a[m-1])&&check(m)) {
ACM(m+1);
} }
}
}
void main() { int count=0;
while(scanf("%d",&n)!=EOF) {
a[1]=1;
printf("Case %d:\n",++count); ACM(2); printf("\n"); }
}
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6 8
Sample Output
Case 1:
1 4 3 2 5 6 1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
#include<stdio.h>
int n,a[21];
int check(int m) { int i;
for(i=m-1;i>=1;i--) { if(a[i]==a[m])
return 0;
} return 1;
}
int isPrime(int m) { int i;
for(i=2;i<m;i++) { if(m%i==0)
return 0;
} return 1;
}
void ACM(int m) {
int i;
if(m>n) { if(isPrime(a[n]+a[1])&&check(n)) {
for(i=1;i<n;i++)
printf("%d ",a[i]); printf("%d\n",a[n]);
}
} else{
for(i=2;i<=n;i++) { a[m]=i;
if(isPrime(a[m]+a[m-1])&&check(m)) {
ACM(m+1);
} }
}
}
void main() { int count=0;
while(scanf("%d",&n)!=EOF) {
a[1]=1;
printf("Case %d:\n",++count); ACM(2); printf("\n"); }
}