题址:http://acm.hdu.edu.cn/showproblem.php?pid=1071
Problem Description
Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?
Note: The point P1 in the picture is the vertex of the parabola.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).
Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.
Sample Input
2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222
Sample Output
33.33
40.69
简单几何题,先是利用二次函数y=a(x-b)^2+c,根据p1,p2,p3点求出a,b,c,即求出函数表达式,再由p2,p3点求直线方程,两个方程求积分即可得到面积。
AC代码:
#include<stdio.h>
double a,b,c,k,d;
double function(double x)
{
return a*x*x*x/3-(2*a*b+k)*x*x/2+(a*b*b+c-d)*x;
}
int main()
{
int n;
double x1,x2,x3,y1,y2,y3; //y=a(x-b)^2+c || y=kx+d
scanf("%d",&n);
while(n--)
{
scanf("%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3);
b=x1;c=y1;a=(y2-c)/(x2-b)/(x2-b);k=(y2-y3)/(x2-x3);d=y2-k*x2;
printf("%.2lf\n",function(x3)-function(x2));
}
return 0;
}