uva568-Just the Facts



  Just the Facts 

The expression  N !, read as `` N  factorial," denotes the product of the first  N  positive integers, where  N  is nonnegative. So, for example,

NN!
01
11
22
36
424
5120
103628800

For this problem, you are to write a program that can compute the last non-zero digit of any factorial for ($0 \le N \le 10000$). For example, if your program is asked to compute the last nonzero digit of 5!, your program should produce ``2" because 5! = 120, and 2 is the last nonzero digit of 120.

Input 

Input to the program is a series of nonnegative integers not exceeding 10000, each on its own line with no other letters, digits or spaces. For each integer  N , you should read the value and compute the last nonzero digit of  N !.

Output 

For each integer input, the program should print exactly one line of output. Each line of output should contain the value  N , right-justified in columns 1 through 5 with leading blanks, not leading zeroes. Columns 6 - 9 must contain ``  ->  " (space hyphen greater space). Column 10 must contain the single last non-zero digit of  N !.

Sample Input 

1
2
26
125
3125
9999

Sample Output 

    1 -> 1
    2 -> 2
   26 -> 4
  125 -> 8
 3125 -> 2
 9999 -> 8


#define LOCAL
#include <iostream>
#include <cstdio>

using namespace std;

int fac(int n)
{
	int sum = 1;
	while(n > 0)
	{
		sum *= n;
		while(sum % 10 == 0)
		{
			sum = sum / 10;
		}
		sum %= 10000;			//?学长说可以直接打表保存,可以0ms,不过。。。
		n--;
	}
	return sum;
}
int main()
{
#ifdef LOCAL
    freopen("data2.in", "r", stdin);
    freopen("data2.out", "w", stdout);
#endif // LOCAL
	int b[10001] = {0};
	for(int i = 1; i <= 10000; ++i)
	{
		b[i] = fac(i);
	}
	int num;
	while(scanf("%d", &num) != EOF)
	{
		if(b[num] / 10 == 0)
        {
            printf("%5d -> %d\n", num, b[num]);
            continue;
        }
        else
        {
            printf("%5d -> %d\n", num, b[num]%10);
        }

	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值